Redirecionamento IP aplicação interna Não está funcionando



  • Boa tarde,

    fiz um port Forward (Firewall: NAT: Port Forward) para apontar a porta 8080 para uma aplicação interna que roda em 192.168.2.2:80.

    Coloquei:
    External port range = 8080
    NAT IP = 192.168.2.2
    Local port= 80

    Maravilha, incrivelmente de dentro da minha rede quando eu chamo meu ip externo http://200.xxx.xxx.xxx:8080 abre minha aplicação que está no 192.168.2.2:80, porém de fora não funciona por nada nesse mundo. Devo estar esquecendo de alguma coisa, talvez básica, mas não consigo mais pensar em nada hehe

    Alguém pode me dar uma luz?

    Obrigado.

    Mainieri



  • @Mainieri:

    fiz um port Forward (Firewall: NAT: Port Forward) para apontar a porta 8080 para uma aplicação interna que roda em 192.168.2.2:80.
    Coloquei:
    External port range = 8080
    NAT IP = 192.168.2.2
    Local port= 80

    Maravilha, incrivelmente de dentro da minha rede quando eu chamo meu ip externo http://200.xxx.xxx.xxx:8080 abre minha aplicação que está no 192.168.2.2:80, porém de fora não funciona por nada nesse mundo. Devo estar esquecendo de alguma coisa, talvez básica, mas não consigo mais pensar em nada hehe

    Alguém pode me dar uma luz?

    O que você colocou em "Destination"? Você precisa especificar o endereço WAN em que o pacote/conexão vai "bater" (principalmente no caso de vc ter mais de um endereço público neste link de dados)!

    Abraços!
    Jack



  • JackL, obrigado por responder.

    em Port Forward não tem opção destination.

    esse IP wan 200.xxx.xxx.xxx é o próprio pfsense.

    Nessa configuração também tem:
    Interface = WAN (Choose which interface this rule applies to.)
    External Address = Any (If you want this rule to apply to another IP address than the address of the interface chosen above, select it here (you need to define Virtual IP addresses first). Note if you are redirecting connections on the LAN, select the "any" option.)



  • @Mainieri:

    Interface = WAN (Choose which interface this rule applies to.)
    External Address = Any (If you want this rule to apply to another IP address than the address of the interface chosen above, select it here (you need to define Virtual IP addresses first). Note if you are redirecting connections on the LAN, select the "any" option.)

    Certo @Mainieri!

    Você deve estar utilizando o PFSense 1.2.3. Neste caso, ao invés de deixar "Any" na opção "External Address", deixe "Interface Address".

    Nota: Certifique-se que o 192.168.2.2 não tenha nenhum fw local bloqueando conexões nateadas!

    Abraços!
    Jack



  • JackL,

    a versão é 1.2.3 sim.

    Deixando "Interface Address" na opção "External Address" não resolveu. Não tem nenhum firewall bloqueando lá, é iis com firewall do windows desabilitado hehe

    O mais estranho, é que se eu jogar o ip externo no navegador dentro da empresa, ele ta fazendo o forward certinho.



  • @Mainieri:

    a versão é 1.2.3 sim.
    Deixando "Interface Address" na opção "External Address" não resolveu. Não tem nenhum firewall bloqueando lá, é iis com firewall do windows desabilitado hehe
    O mais estranho, é que se eu jogar o ip externo no navegador dentro da empresa, ele ta fazendo o forward certinho.

    @Mainieri,

    Baseado no que você respondeu acerca das tuas configurações e cenário, certifique-se que na aba "LAN" no teu "Firewall->Rules", as conexões HTTP originadas pelo teu servidor (192.168.2.2) estam explicitamente liberadas. O que pode estar ocorrendo é que o IIS não consegue responder as requisições para quem está de fora da tua rede local pq as tuas regras não permitem.

    Tente testar também a conexão, de uma máquina na internet, através do telnet:

    telnet ip_publico_do_seu_servidor 8080

    Verifique se a conexão acontece ou é encerrada!

    Abraços!
    Jack



  • Em conversa com pessoal no irc conseguimos resolver o problema:

    <@vcoque> o pfSense e gateway da maquina com ip 192.168.2.2?
    <jccash>essa pergunta é muito boa, vou verificar (é pra ser o gateway sim)
    <@JackL> é… tipo se não for o gateway, o vcoque acabou de resolver o teu problema! :D
    <@JackL> JCCash: vai lá no CentOS e dê um "route -n"
    <jccash>uns 3 meses atrás, foi trocado de forefront para pfsense
    <jccash>e provavelmente a aplicação está com gateway ip antigo do forefront
    <jccash>eu vou testar aqui
    <@JackL> então fechou JCCash

    O gateway na aplicação não era o ip do pfsense, após alterar o forward funcionou perfeitamente.

    Muito obrigado pela ajuda JackL e vcoque, e desculpem pela demora em responder.

    O problema está resolvido.</jccash></jccash></jccash></jccash>


Locked