Simple Operation, or so I thought…



  • How do I get a port forward to work? (this is for remote desktop)

    I go into Firewall: NAT: Port Forward and create a new entry.
    I leave everything default, TCP, Destination: WAN address, port X.
    Then set the Redirect IP and Port to my internal IP and the same port as incoming, X.
    I have it linked to a Rule automatically.

    Am I missing something? I have internet on this PC and can ping it from the pfSense box and vice versa. But when I try to remote desktop, it doesn't respond at all. The port is not open according to any port scanner I have used. I know the settings are correct on the PC itself as it works fine when I plug into our previous network.

    Any ideas?



  • I do not know what you are trying to explain but you only need PortForward if your pfsense is doing NAT and you want to connect from WAN to a client on LAN.

    Then you need the following portforward:

    source port: any
    source IP: any
    Destination IP: WAN address
    Destination port: 3389 OR some-port-of-your-choice
    Redirect IP: IP-of-the-client
    Redirect port: 3389 (RemoteDesktoProtocol)

    If you are using the Windows Remote Desktop client and you are using an othe rport thant 3389 you have to put the other port after the IP address:
    WAN-IP-address:4711



  • Thanks, that confirms what I thought. So I have it set just like that and it isn't doing anything. I am trying to be able to remote in from home, so it is from the WAN.



  • Then check the firewall of the destination client (disable the firewall for testing purposes).
    If you are using windows 7 and windows xp then there are different "security" options when you use RemoteDesktop. You have to check this on the destination client.

    Perhaps you could post a screenshot of your NAT rule and your firewall rules.



  • I finally found out what the issue was. We were having some IP address conflicts and so the port request wasn't even reaching the firewall.


Log in to reply