PfSense packages not showing



  • My problem is that when I go to packages and get this message:

    "Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity."

    I am able to browse the Internet fine as-well as other types of traffic. I have configured the DNS servers to Google's "8.8.8.8" & "8.8.4.4". I have also used OpenDNS servers. The thing is that when I use pfSenses own DNS Lookup in the Diagnostics section I get the following results:

    www.pfsense.compfsense.com

    then I do:

    pfsense.com = 69.64.6.21

    Below is the resolution time per server results:

    Server Query time
    8.8.8.8 45 msec
    8.8.4.4 33 msec

    I have updated to the latest version yesterday as I thought this might solve it. I have never been able to view and install packages since installing it. My current version is below:

    2.0-RC3 (i386)
    built on Mon Aug 29 11:53:27 EDT 2011

    pfSense does not seem to have a problem looking up "www.pfsense.com", so why when I go to available packages I get the message shown above and no list of packages.

    Is there a work around I can do this, maybe altering some configuration settings. For example changing "www.pfsense.com" to "pfsense.com" to see if that works or is their some other work around. Can someone point me in the right direction. Any input would be great  ;D


  • Rebel Alliance Developer Netgate

    Do you have a proxy or something else in front of that box which would cause a web request to fail or show something different?

    From the console, try:

    fetch -o - http://www.pfsense.org/packages/pkg_config.8.xml
    

    See if you get back the package xml or an error or some other page.



  • Thanks jimp ;D, sorry I should of said I was setting it up behind an Untangle box, tried it with a straight connection to the internet and brought up packages no problem. The command also worked when behind the untangle box. Once I get pfSense all set up I will replace Untangle and have Untangle in transparent bridge mode. Once again thanks  ;D


Log in to reply