Error when setting DNS Servers



  • Hello,

    I got this error when trying to setup my DNS Servers in System > General Setup :

    
    The gateway specified for DNS server '10.130.0.142' is not from the same Address Family as gateway ''.
    The gateway specified for DNS server '10.14.32.30' is not from the same Address Family as gateway ''.
    The gateway specified for DNS server '' is not from the same Address Family as gateway ''.
    The gateway specified for DNS server '' is not from the same Address Family as gateway ''.
    
    

    My version :
    2.1-DEVELOPMENT  (amd64)
    built on Wed Aug 31 17:02:22 EDT 2011

    Thank you !



  • Will investigate.



  • Do you you have news on this problem ?

    I can't update my general configuration unless i patch the code to remove the DNS checks.



  • Have not gotten round to it.



  • Can not replicate anymore, does this still fail for you.



  • Hello,

    Got the same problem.

    My build: 2.1-DEVELOPMENT-pfSense (i386), the lastest available until now (that's the 2011-Oct-22 01:44:57 build on iso image)

    Perhaps some more informations:

    I configured 3 NIC:
    em0 (LAN) ipv4 (192.168.x.x) and IPv6 (2001:db8:0:f101::1079:1/64)
    em1_vlan15 (Internet area) IPv6 only (2001:db8:0:0::4/64)
    em1_vlan16 (Other network) IPV6 only (where DNS are located) (2001:db8:0:1::1/64)

    DNS are : 2001:db8:0:1::53:1 and 2001:db8:0:1::53:2

    I tried to setup another DNS (let's say 8.8.4.4), but it is the same problem.

    I have no default gw (v4 and/or v6) set.

    If I set a V4 gw and a V4 IP on WAN (em1_lan15) the update can be done.

    I hope that helps ;-)

    Regards,
    nicolas.

    PS: IPv6 IP are in documentation Area … do not use them asis ;-)



  • Hi,

    same here.

    Added without the setup wizard on WAN and LAN Interface an IPv4 Adress and tryed to add an IPv4 DNS Server. Same error as alexis.olivier.
    Same with IPv6 Adress on the Interfaces and DNS Server.

    Greetings


  • LAYER 8 Global Moderator

    I just went in and changed mine to an ipv6 and ipv4 google from the normal ones I have set 127.0.0.1 and 4.2.2.2

    No issues - see attached

    2.1-DEVELOPMENT (i386)
    built on Fri Oct 21 12:51:56 EDT 2011
    FreeBSD 8.1-RELEASE-p6

    gitsync as of last night




  • Using

    http://files.pfsense.org/jimp/ipv6/

    pfSense-2.1-DEVELOPMENT-amd64.iso.gz 2011-Oct-22 02:32:39

    Greetings



  • Same error with the new build.

    If I edit the restore file with 2 ipv6 dns server, both are configured in pfsense after the restore.

    But Package and Update management doesn't work.

    Unable to communicate with www.pfsense.com. Please verify DNS and interface configuration, and that pfSense has functional Internet connectivity.

    DNS Lookup with the both IPv6 DNS Server works fine.

    Diagnostic -> DNS Lookup

    pfsense.com = 69.64.6.21

    2a01:4f8:120:5121:6::53 6 msec
    2001:4d88:1ffc:409:1::53 8 msec

    Any Idears ?

    Thx

    Greetings


Log in to reply