Problems with apcupsd and/or nut



  • I'm running 1.2.3 and I tried installing the apcupsd (apcupsd-3.14.8_2.tbz), I got everything done but when I tried to start it the terminal gave me /libexec/ld-elf.so.1: Shared object "libwrap.so.6" not found, required by "apcupsd". I have the ups connected to my media server that is also running apcupsd so this will be a remote connection from pfSense.  I could not figure out what package that libwrap.so.6 is in so I could install it, so that's the first thing I want to know. The next thing is, with failing at that, I decided to install the nut package. Is there a way to connect to apcupsd with nut?

    Thanks



  • libwrap.so.6 is not part of a package, its part of FreeBSD.
    It appears the package you are attempting to use is newer then
    FreeBSD 7.0-Release, which 1.2.3 is based off of.

    ls -al /usr/lib/libwrap.* will show you what files you have. You probably
    have libwrap.so.5

    Using ln -s, you may be able to link libwrap.so.6 to libwrap.so.5, and it
    may work. But it may also not work / melt your box / kill your cat…

    Otherwise, try installing the package for a 7.x variant (not sure when
    libwrap.so.6 was introduced)


Log in to reply