DHCPv6 + Unbound = no IPv6 love



  • Hey guys,

    I'm not sure this belongs here, as I'm semi-positive it's more an Unbound thing… but I know some of you are running both of these and I'm wondering if anyone else is see it.

    Since updating this last weekend and running into this issue (which is fixed BTW), I've been having issues surfing the IPv6 web. This morning I updated again so I'm currently at:

    2.1-DEVELOPMENT (i386)
    built on Mon Sep 5 04:07:51 EDT 2011
    (I do auto gitsyncs at the time of snapshot updates also)

    But was not getting any addresses handed out via DHCPv6… I tried both "Assisted" & "Managed" in the DHCPv6 server settings, and while Assisted would let clients auto gen their own address, they could still not surf the web.

    Just a bit ago I tried switching back to dnsmasq from unbound and am now again able to grab v6 addresses from DHCP with some clients (right now using Managed) and surf v6 sites.

    I question whether or not unbound could be the cause, but it certainly seems to be the reason for the v6 issues having it on....

    I don't know, I'm kinda at a lose and just wondered if anyone else is seeing any wonkyness?



  • Not sure if this has anything to do with anything… but while switching back and forth between dnsmasq & unbound I do notice that:

    1- while using dnsmasq I can grab a DHCPv6 address fine and I have 2 DNS servers listed, which are both the internal address for my LAN (one v4 and one v6)
    2- while using unbound the v6 address previously grabbed from DHCP is listed as deprecated and while the v4 DNS server is still my LAN address, the v6 DNS server now listed is the v6 DNS server I assigned in the System : General Setup : DNS Servers



  • There is currently no integration between DHCP and Unbound, in other words you will need to assign the IPs you want given o your DHCP clients by manually configuring them in the DHCP configuration page. Currently the way v4+v6 works is that when the DHCP service is set up it checks for:

    • Manually configured DNS servers and assigns those, if those are not configured
    • It then checks to see if dnsmasq is enabled. If it is enabled, it assigns the IP(s) configured on the LAN. If it is not enabled
    • it assigns the DNS servers configured in System->General Setup to the DHCP clients.

    I know databeestje has also mentioned some other rtadvd fixes that he is looking into fixing, but the above still stands until Unbound is fully integrated. Which I guess is now becoming a necessity…so best I get cracking :)



  • Hey wagonza, thanks for the reply!

    I'm won't have the time today to futz around with it, but will tomorrow… and iirc, I used to have all that info plugged in to the DHCP server config page but then pulled it out for some reason or another. I'll replace it all tomorrow and post back, but that makes total sense, thanks again man!


Log in to reply