Help with SPA-3000 VoIP Box?



  • Hi guys, im completely new to pfsense and all non-windows platforms and have only just switched to using this 'style' of router.

    As a router, everything on Pfsense is working great and is much better than the old system…except for one rather major (for me) problem...i can't get my Linksys/Sipura SPA-3000A VoIP ATA working.

    It works perfectly fine on the old DLink router, and i THINK it worked on ClarkConnect (though since i switched to pfsense, i can no longer confirm this), but it simply will not register with my voip provider when i have it running thru the pfsense box.

    I have tried forwarding various ports, but given that in its WebGui i can see that it is cycling ports all the time to try and get a connection. This is why i had it in the "DMZ" of the old router. Pfsense doesn't seem to have the same option (i suppose because it can do real DMZ, but due to my physical layout of my network, it would be a great inconvenience to have to run the SPA to a separate NIC).

    So does anyone have any suggestions on how i can get it to work? Cos if i cant get this working, i think im going to have to switch to something else.

    Thanks in advance guys,



  • PF (the filter used by pfSense) scrambles ports for advanced security by default. Some VOIP-Providers don't like that. Have a look at the following links how to shut down this behaviour for your VOIP-Phone:

    http://forum.pfsense.org/index.php/topic,104.msg5876.html#msg5876
    http://forum.pfsense.org/index.php/topic,1047.msg12752.html#msg12752

    There are other threads covering this too. Search for "static port" if you still have questions.


Log in to reply