NAT + VPN



  • Salve mais uma vez outra duvida chata bom tenho winserver 2003 com AD e nele esta configurado VPN tentei colocar as portas vpn no pfsense para este servidor mas não consigo conectar, fiz o procedimento de vpn ppptp  pelo pf e deu certo mas queria que fosse pelo meu AD pois ele tem regras de mudar senha a cada 15 dias e no pfsense não achei esta opção tendo que colocar usuarios um por um



  • @alexlevita:

    Salve mais uma vez outra duvida chata bom tenho winserver 2003 com AD e nele esta configurado VPN tentei colocar as portas vpn no pfsense para este servidor mas não consigo conectar, fiz o procedimento de vpn ppptp  pelo pf e deu certo mas queria que fosse pelo meu AD pois ele tem regras de mudar senha a cada 15 dias e no pfsense não achei esta opção tendo que colocar usuarios um por um

    Vixe maria @alexlevita,

    Este seu post está um "cadinho" confuso como dizem lá em MG! :-)

    Mas vamos lá, acho que captei a vossa mensagem… Você quer que seus clientes VPN continuem conectando (fechando a VPN) no seu Win2003 Server que agora está atrás do PFSense... correto?

    Se for isso, realize o NAT (port forward) das seguintes portas para o seu Server Windows (se você não sabe como fazer NAT no PFSense, siga o exemplo: http://forum.pfsense.org/index.php/topic,37917.msg203176.html#msg203176):

    TCP/1723
    GRE/47
    UDP/1701

    Isso deve resolver o seu problema!

    Abraços!
    Jack



  • Fiz exatamente isto mas não conecta, o TS funciona masvpn ele fica mo tempão reconhecendo usuario e senha mas não conecta.



  • Voce tentou usar a opção de Forward no pptp server do pfsense?



  • @alexlevita:

    Fiz exatamente isto mas não conecta, o TS funciona masvpn ele fica mo tempão reconhecendo usuario e senha mas não conecta.

    @alexlevita:

    Fiz exatamente isto mas não conecta, o TS funciona masvpn ele fica mo tempão reconhecendo usuario e senha mas não conecta.

    @alexlevita,

    Verifique se o "firewall" do seu Win2003 ou um eventual antivírus instalado no servidor não está bloqueando as conexões dos clientes VPN.

    Por "desencargo", teste também a conexão (com uma máquina fora da sua rede local, claro):

    telnet ip_público_que_está_configurado_no_pfsense 1723

    Se a conexão ocorrer, pode ser algo relativo as tuas credenciais ou opções de encapsulamento do discador no cliente. Se a conexão falhar, verifique novamente as portas liberadas no seu PFSense e as questões levantadas no primeiro parágrafo deste post.

    Abraços!
    Jack



  • @JackL:

    @alexlevita:

    Fiz exatamente isto mas não conecta, o TS funciona masvpn ele fica mo tempão reconhecendo usuario e senha mas não conecta.

    @alexlevita:

    Fiz exatamente isto mas não conecta, o TS funciona masvpn ele fica mo tempão reconhecendo usuario e senha mas não conecta.

    @alexlevita,

    Verifique se o "firewall" do seu Win2003 ou um eventual antivírus instalado no servidor não está bloqueando as conexões dos clientes VPN.

    Por "desencargo", teste também a conexão (com uma máquina fora da sua rede local, claro):

    telnet ip_público_que_está_configurado_no_pfsense 1723

    Se a conexão ocorrer, pode ser algo relativo as tuas credenciais ou opções de encapsulamento do discador no cliente. Se a conexão falhar, verifique novamente as portas liberadas no seu PFSense e as questões levantadas no primeiro parágrafo deste post.

    Abraços!
    Jack

    Então o meu cenario anterior era este setup,

    tinha um servidor Win 2003 com AD + antivirus Mcafee.
    e servidor de firewall+proxy com slackware com regras de iptables + squid
    e a vpn funcionava normal.

    acabou queimando o slackware e resolvi experimentar o pfsense como proxy ele funcionou perfeitamente mas realmente estou tendo este problema com a vpn, vou tentar mais tarde em um ambiente virtual para ver se relamente o problema esta na rede onde estou tentando configurar isto.


Log in to reply