Port Forwarding not working



  • Hi guys,

    I currently have my PfSense router down at the moment for an OS reinstall because I have been having issues with it, and I am curious what could be causing them.
    For some reason, I was not able to forward ports through PfSense so I could run a Game Server on the LAN side of it (For the WAN side of it).

    The way the network was set up:

    Internet –-- Modem Router (LAN - 10.5.14.254) with Static Routes to 10.5.15.xxx via the Gateway: 10.5.14.253 –-- PfSense VM (WAN IP: 10.5.14.253, LAN IP: 10.5.15.253 - DHCP Range: 10.5.15.2 - 10.5.15.124) –-- Unmanaged Gigabit Switch –--Servers

    I had set the PfSense VM as a DMZ server on the Modem Router (Which handles the ADSL WAN connection via PPPoA so setting the Modem to Bridging mode is not an option because PfSense only handles PPP sessions over PPPoE).

    I tried to run a Game Server on the LAN side of the PfSense VM for the Internet side of things but the PfSense distro was not opening the port (Even though it said it was open).
    I also tried to put the Game Server on the LAN side of the Modem Router (Into the 2nd port of it) and it worked because it wasn't behind PfSense.

    Due to the way I have my network set up, all devices should be on the LAN side of PfSense all the time but as I said, it doesn't seem to be opening the ports.
    Is it because I run the Modem Router on the 10.5.14.xxx range and the Server is on the 10.5.15.xxx range? (All devices on the 10.5.15.xxx range have perfect internet access).

    I have tried to manually enter the port on the Modem Router and forward it to the PfSense IP (10.5.14.253) and forward it through PfSense to the server but that didn't work either.

    What am I doing wrong? Upgrading to 2.0 RC3 didn't make a difference.

    Thanks for your replies



  • Usually if your adsl is PPPoA you can enter your credentials into the fields for PPPoE and it works.
    Have you tried that?

    I've met some modem/routers which handle the "DMZ-IP" very strange…. Basically it didn't work at all.
    A normal portforward 1-65535 to the IP of the pfSense worked however.

    Since you're running the pfSense in a VM.
    Did you check if the VM actually allows inbound connections to the pfSense?
    Firewall on the parent-system?

    Also: http://doc.pfsense.org/index.php/Port_Forward_Troubleshooting



  • I am aware PPPoE works on my ADSL connection but I don't like using it because I don't receive as much throughput (I like having the max I can get).

    The exchange (Central Office) I am on is basically owned by British Telecom: Wholesale who only have ATM DSLAMs installed in it at the moment (Upgrading to MSANs by 2012).

    As for the port forwarding problem, I am using VMware Server as the Software for hosting the VM (Does it allow inbound connections by default?).
    I have just finished reinstalling the OS on the node which the VM is on (It runs Windows Server 2003 and I don't think the firewall is enabled as I can't access it by default).

    On the node, it basically goes:  LAN Port 1 – VMWare Adaptor 1 -- PfSense -- VMWare Adaptor 2 -- LAN Port 2.

    I might try Port Forwarding the entire port range to see if that works, when I get the VM back up.

    Anything else which could be causing it to not forward the ports? I need to also mention, I am on dynamic external IP addresses (My ISP doesn't offer Static IP Addresses).

    I did try and manually forward the ports to PfSense through the router.



  • For some reason the port forwards do not get passed onto the devices when forwarded through both the router and PfSense.

    I can access unlocked ports from the WAN side of PfSense but I can't from the internet (When I've forwarded the ports to PfSense on my router).

    Any idea what's wrong with it? I've tried both setting PfSense as the DMZ server and manually forwarding ports 0-65535 to PfSense but it still doesn't work.

    I'm using a DG834GT as my Modem Router.



  • Hi m8

    Make sure that the pfsense router is in the DMZ zone. Next go to the web interface of pfSense and go to the tab interfaces ==> WAN. After that make sure that you look for the title "Private networks" and DISABLE "Block private networks" and "Block bogon networks"!!!

    I had the same problem as you today and I've almost thrown the pc into pieces out of frustation thanks to those checkboxes.

    I hope it solves your problem as well.

    Grtz


Log in to reply