Gitsync error help [Resolved]



  • Ok guys, I got my IPv4 all configured like I want it. Was trying to get started on IPv6. I'm already stuck before I can even begin. I'm working on doing the very first option & am getting an error that the URL for git doesn't exist. I guess a git client isn't installed by default, & since this is my first time running gitsync it needs to download. I keep getting the following error for the first step in the tutorial.

    Install your pfSense 2.0 first, then make sure that all ipv4 connectivity works. You can launch option 12 from the shell menu (also available via ssh), and enter "playback gitsync".

    Attached image of my error.

    ![Gitsync Error.png](/public/imported_attachments/1/Gitsync Error.png)
    ![Gitsync Error.png_thumb](/public/imported_attachments/1/Gitsync Error.png_thumb)



  • connection reset by peer means the ftp download reset somewhere along the path, just try again. This is just one of those things you occasionally run into when surfing the web.

    It happens every now and then on long lasting tcp sessions too like IRC. Something in the path from here to there has a hickup and then the connection resets.



  • I've tried doing the same thing many many times. I probably tried it over 50 times yesterday with same error everytime. Tried it again today with same error.

    However what makes me mad is that I browsed to that exact website url listed & was able to get a download prompt in firefox without a problem yesterday. Also used a FTP client to verify that the dir names were all still the same, which they are.

    Like I said I can get a download prompt for git.tbz, through firefox. Can I download the package & manually upload it to my pfsense box?

    Edit:Now i'm getting the same connection reset error in FF/IE when trying to download file directly from that FTP url. I guess there is something wrong with free BSD's ftp server. when you browse to the last folder that the file is in, i'm using core ftp. it has to load 1909682 files in the directory. So it takes it forever.

    Edit 2:Just refreshed page in FF & it let me download the git.tbz. However PFsense box is still not updating it.



  • try using pkg_add -r git from the prompt. Alternatively find a mirror close by and supply that url.

    e.g. pkg_add -r



  • Thank you, this worked. If anyone wants to upgrade to IPv6 & is having problems due to freebsd ftp servers not serving git correctly.

    Go here, http://www.freebsd.org/doc/handbook/mirrors-ftp.html

    I used Primary mirror sites. Find a link to git. Pathname should be similar to the denied pathname that it was unable to find on main freebsd server. Do sudo su, then run pkg_add -r <url to="" git.tbz="">. Installed it for me, then it worked.</url>


Log in to reply