FreeRADIUS package is not updated properly from pkg v1.0.3 to pkg v1.0.4



  • pkg_mgr_install.php?mode=reinstallpkg&pkg=freeradius page died with fatal error:

    Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69



  • Not sure if this error is related to the package itself or something else.

    Is it i386 or amd64 ?
    Did you try with "Clear package locks" ?



  • i386

    "Clear package locks" didn't help



  • reverted the changes from 1.0.4 back to 1.0.3 but have to wait till it's merged.
    Hope this will fix it - not sure where the problem is/was.

    It stucks on "Loading package configuration… "

    Sorry for that....


  • Rebel Alliance Developer Netgate

    I fixed it, there were problems in the freeradius.xml file - wasn't related to the version.



  • Thanks !



  • i still have this problem for 2.0 amd64



  • I installed the 1.0.4 version some hours ago on amd64 and it is working for me.

    The error Alan_nn posted in the first post was related to a syntax error in the freeradius.xml.
    jimp fixed it and it is working.

    The verison bump to 1.0.4 is related to this change:

    From:

    
    Simultaneous-Use += 1;
    
    

    To:

    
    Simultaneous-Use := 1;
    
    

    Perhaps clear package lock and reinstall freeradius again.



  • the error i get is "Fatal error: Cannot create references to/from string offsets nor overloaded objects in /etc/inc/xmlparse.inc on line 69 "

    How do i "clear package lock" ? DIAGNOSTICS -> BACKUP/RESTORE -> Clear Package Lock

    this did not help… i think im doing something wrong??

    $ find / -name freeradius.xml
    /usr/local/pkg/freeradius.xml

    i cant find "Simultaneous-Use += 1;" in that file.. ? ??



  • Simultaneous-Use is in freeradius.inc
    This was the change which bumped the version from 1.0.3 to 1.0.4

    The syntax error which jimp fixed weeks ago was in freeradius.xml

    Try this:
    All configurations you did in freeradius is placxed in your config file you can download in DIAGNOSTICS -> BACKUP/RESTORE.

    Try to delete or rename the alle freeradius related files in /usr/local/pkg and then do a reinstallation of freeradius. Perhaps it isn't replacing old files with the new ones.



  • i am sorry that i did not tell you that i haven't made any changes to my freeradius so when i removed the XML file and upgraded it worked. :)



  • Thanks for feedback.


Log in to reply