Unblock MSN (I am the admin)



  • Hi to all,  I have installed pfsense 2RC3 with Squid+Squidguard in non-transparent mode, with local authentication.

    I have full access to all sites (shallalist blacklist installed).

    But when trying to connect to Windows Live Messenger fail in the check for Ports (only if using the proxy in iexplorer, if I connect direct can log to messenger fine).

    In /var/squid/log I see the next:

    1316030550.416      0 192.168.149.99 TCP_DENIED/407 1686 CONNECT login.live.com:443 - NONE/- text/html
    1316030552.128      0 192.168.149.99 TCP_DENIED/407 1737 POST http://ssw.live.com/uploaddata.aspx - NONE/- text/html
    1316030552.234      0 192.168.149.99 TCP_DENIED/407 1686 CONNECT login.live.com:443 - NONE/- text/html

    I have not configured anything to block messenger, It seems that squid in pfsense comes with this by default.

    What is the correct way to enable msn for me and some users and block it to everyone else.

    thanks in advance.

    Richard



  • If you are using auth and msn client can't use your authentication method, you will ser this error.
    Check in log if urls that has a tcp_miss has also a username.

    You may need To create An acl by client address and map msn urls.


Log in to reply