Need help troubleshooting serial connection with Soekris Net5501-70



  • Using the instructions found on page 38 of "pfSense, the Definitive Guide," I issued the following command:

    gunzip -c pfSense-2.0-RC3-4g-i386-20110621-1821-nanobsd.img.gz | dd of=/dev/sde bs=16k

    it appeared to successfully install the image file to my 4GB Transcend CF card.

    Then I installed the CF card in the hardware, as shown in the picture linked here: https://picasaweb.google.com/lh/photo/mgrT76AqG5smDl6DFE2y-p5oqxvmnDu2HzE-a8Qi6yg?feat=directlink

    Next, per the instructions on page 41 of the Definitive Guide, I used a null modem cable to connect the serial port on my Ubuntu 11.04 box, to the serial port on the 5501.
    (
    to check the status of my computer's serial port, I ran dmesg | grep tty and got the following output:
    [    0.000000] console [tty0] enabled
    [    1.431105] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    [    1.740643] 00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    )

    After completing the above steps, I started Minicom, and see the following output:

    Welcome to minicom 2.5

    OPTIONS: I18n                                                               
    Compiled on Feb  5 2011, 06:31:42.                                         
    Port /dev/ttyS0

    Press CTRL-M Z for help on special keys

    (I've got it set for 9600 8N1… have also tried 19200 8N1).

    Finally, I plugged the power cable into the 5501, and waited for any output on the Minicom screen.

    PROBLEM:
    I have yet to see any output... even the unintelligible characters you might see when you connect the Cisco console cable to a terminal with the wrong speed settings.

    Additionally, I have plugged my computer into port 0 of the 5501, and manually set my computer's NIC to 192.168.1.2, with the hope that the 192.168.1.1 default address was already preconfigured in pfSense... but alas, no love.

    Any suggestions?

    Thanks,
    Jones



  • If you have setup this box with console connection you could setup dhcp to use in lan, that's how you know for sure what interface is right one.



  • Well, I think that's the problem. I haven't been able to make a console connection yet. 95% of the time, it's operator error (at least for me)… but I just don't know what I'm missing.

    Once I can get a console connection established, and get to a text menu of some sort, I think I'll have this thing whipped. But for now, I'm stuck.



  • IIRC, the box will be sitting at a prompt to assign interfaces, so you won't be able to connect via the network.
    Do you have another device like a Cisco router you can use to sanity check your workstation setup?
    I've used tip and putty from UNIX to connect to the serial console, but like most things it is less user friendly than connecting from a Windows box. If you have verified the workstation setup, another possibility is that the image was not written properly. I'm not so familiar with Ubuntu, but did the cf card really show up as /dev/sde?



  • I've got a blinking cursor in Minicom, and a notification in the bottom bar that tells me I'm online. But there is no prompt asking me to assign interfaces.

    Funny you should ask about the Cisco box. I've got a PIX 501 here that the pfSense box is going to replace, because it finally died after 8 years of solid service. However, it's well and truly dead, so any output I got from it using the console port was garbled beyond recognition (even at 9600 8N1).

    The CF card showed up as /dev/sde, probably because I have it inserted into a multi-card reader (CF, SD, etc, etc)… also purchased from Soekris.

    I believe the image was written properly. The Ubuntu disk utility shows two 2GB FreeBSD partitions [/dev/sde1 and /dev/sde2] (the first of which is bootable), as well as a third FreeBSD partition [/dev/sde3] (of only 53 MB) of file type ufs (plus 70 MB of unused space).



  • goto that box bios and look what console it has there. I think there is a mismatch between hardware and pfsense speed settings



  • How do I get to the box bios?

    As I understand it, pfSense has a default setting of 9600 8/N/1, and the Soekris Net5501 has a default setting of 19200 8/N/1.

    However, I've tried each setting, and still I get no output from minicom at all. Just the following introductory text staring at me:

    Welcome to minicom 2.5

    OPTIONS: I18n                                                               
    Compiled on Feb  5 2011, 06:31:42.                                         
    Port /dev/ttyS0

    Press CTRL-M Z for help on special keys

    The bottom (information) bar has the following information (from left to right):
    CTRL-M Z for help | 19200 8N1 | N0R | Minicom 2.5 | VT102 | Online 00:01



  • 19200 8N1 is correct for the Soekris. If you are connected when the box is powered on, you should see the post and BIOS information. Once pfSense boots, you will get garbled output, as it is set to 9600. I set my Alix/Soekris boxes to 9600 for consistency. You might try another machine, even (I know, I know) a Windows box with putty.
    It would be helpful to rule out problems with the terminal on the workstation. Does Ubuntu have cu or tip? I usually run a serial console on my BSD boxes, have you verified you are not running a listener on the port?



  • I suppose I should confess that this is my first outing with Minicom (and GtkTerm, and MoSerial)… I'm much more familiar with Hyperterminal (so I've asked my wife to bring her old XP laptop home from work).

    Yes, Ubuntu has cu, but I know even less about that.

    While trying all of the above methods of connecting to the 5501's serial port, I have had the nagging sensation that it was something incredibly simple that I was missing.

    Question: What is a listener?... and how do I find out if I am running one on the port? The Ubuntu box is new, and the Motherboard didn't have a serial connection. So, I bought a serial expansion card and plugged the cable in to the appropriate plug-in on the Motherboard. When i query the system using dmesg | grep tty, it tells me that the serial device ttyS0 is active.

    I also went out this AM and picked up a USB to Serial adapter, and yet another null modem cable (in the event that it's my serial card).

    Another step I have tried is to reformat the CF card (removing the latest iteration of version 2.0... RC3 I think), and installing pfSense-1.2.3-RELEASE-4g-nanobsd.img.gz ... Based solely on the impression I received that the default LAN IP address was already set to 192.168.1.1, and that I could plug my Ubuntu box into it with a crossover cable, program it for SSH, and then go in that way to change the IP address. But that didn't work either.

    Jones

    After some other work, I'm going to sit down and see what I can do about it.



  • The 1.2.3 release needed manual assignment on the interfaces also, so that's not going to help much. 2.0 final is out, you might try that. It may still default to sis interfaces instead of vr. Don't worry about the listener, I'm pretty sure you have to set that up specifically. Here is the Soekris Wiki notes on the console:
    http://wiki.soekris.info/Connecting_to_the_serial_console
    Using putty from an XP box with a built in serial port is pretty easy, you could try that if you have a box handy.



  • Yes, I found that out the [really not so] hard way. But WOO-HOO! the serial connection is up. Unfortunately, I cannot with any degree of surety, point to the change that made it possible.

    My suspicion is that either my PC's serial port (which I added on and plugged into the appropriate port on the motherboad), or the null modem cable, was faulty.

    For when I went out and picked up a USB to Serial adapter, and new null modem cable… it worked, both with Minicom, and GTKTerm.

    I have what looks to be one last hurdle to overcome, but since it's a different issue, I'll start a new thread.


Log in to reply