[SOLVED] Strange Route issue (No network from LAN, while working from WAN)



  • Hi, guys!
    I have the following situation:
    ADSL modem is providing my pfsense box with Internet, there IS ping from WAN to any Internet site, but no such ping from LAN-side of the network. The strange (some would say funny) thing is that I am outside of the country, and I can access the router via the WAN interface and manage it, but none from LAN could do anything in Internet. More technical details:

    ADSL modem: internal IP 192.168.1.1 , DNS is automatically assigned to its internal network interface

    pfsense WAN (rl0): set in Interfaces -> WAN  type: DHCP, DHCP client configuration - set the name of the router itself, and both ticks on "Block private networks" and "Block bogon networks" are checked on (marked)

    pfsense LAN (rl1) : set in Interfaces -> LAN type: static, address: 192.168.0.254 ; Gateway: 192.168.1.1

    $ netstat -rn
    Routing tables

    Internet:
    Destination        Gateway            Flags    Refs      Use  Netif Expire
    default            192.168.1.1        UGS         0   395026    rl0
    8.8.8.8            192.168.1.1        UGHS        0        0    rl0
    127.0.0.1          link#7             UH          0      131    lo0
    192.168.0.0/24     link#4             U           0       41    rl1
    192.168.0.254      192.168.1.1        UGHS        0      216    rl0
    192.168.1.0/24     link#1             U           0        0    rl0
    192.168.1.1        00:30:18:b2:60:10  UHS         0    16963    rl0
    192.168.1.2        link#1             UHS         0        0    lo0
    212.39.90.42       192.168.1.1        UGHS        0       53    rl0

    Ping from WAN to modem

    Ping output:
    PING 192.168.1.1 (192.168.1.1) from 192.168.1.2: 56 data bytes
    64 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=1.411 ms
    64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=1.245 ms
    64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=1.587 ms

    –- 192.168.1.1 ping statistics ---
    3 packets transmitted, 3 packets received, 0.0% packet loss
    round-trip min/avg/max/stddev = 1.245/1.414/1.587/0.140 ms

    Ping from LAN to modem

    Ping output:
    PING 192.168.1.1 (192.168.1.1) from 192.168.0.254: 56 data bytes

    –- 192.168.1.1 ping statistics ---
    3 packets transmitted, 0 packets received, 100.0% packet loss

    Version 2.0-RC3  (i386)
    built on Mon Jul 4 16:48:37 EDT 2011

    One side detail is, like I said, that I am 1400 km away from this machine, and have no physical access to machine, which made ~67 days uptime, before rebooting for unknown reason. I know this may seem unrelated to the problem, but I am trying to clarify all the details that one wants to be provided with. Let me know what do you need as another info, I will supply it.
    Probably the trouble is obvious and very easy to be solved by somebody skillful, but I can not see the reason for failure to connect LAN to WAN - somehow something went wrong… Please note, that I haven't made any changes regarding routing in recent 3 months.
    So in conclusion - I would like to ask for an advice how to fix this issue remotely. Thank you very much in advance!



  • SOLVED!
    Found some old config file - couple of days old, restored from it and after some time, so far the system is working, and connected from LAN to Internet. So I am sorry for making a lot of noise for no-thing. Anyways, thank you very much indeed for attention, and keep smiling, guys and girls! :)


Log in to reply