Issues setting up the interfaces



  • Hello,

    I just downloaded pfSense (the latest snapshot, i believe) to check it out on one of my spare ibm x330 boxes.

    pfsense gave me some initial trouble while booting (hangs, solved by disabling the floppy controller in the bios), after that everything was alright up to the point where the interfaces are configured.

    Auto-detection doesn't work at all, neither does setting the interfaces manually.

    All attempts of setting up the interfaces end in the following error message:

    "Warning: array_key_exists(): The second argument should be either an array or an object in /etc/inc/config.inc on line 1129"

    any pointers? I'm downloading the stable iso to check if that works as we speak.

    thanks.



  • You must be doing something wrong. I have the same box and the 2 onboard fxp nics are detected just fine as well as the additional realtek based switchcard that I have in this box. I had to disable the floppy controller as well btw ;)



  • Turns out that I was indeed "doing something wrong".

    Your report encouraged me to put some more thought into this, so I freed up another x330 box and autodetected both onboard nics right off the bat.
    After closer inspection it turned out that both nics on the other x330 were disabled in the bios.
    That'll teach me to reset the bios to default after buying used pcs… another lesson learned. ;)



  • Great  :)

    Btw, if you get strange logs on this box about time going nuts and openntpd has a hard time to keep your time accurate (which was the case at my box) have a look at http://www.freebsd.org/doc/en_US.ISO8859-1/books/faq/troubleshoot.html#LAPTOP-CLOCK-SKEW

    I had to set my box to the following timecounter-hardware to make it run without issues:

    $ sysctl kern.timecounter.hardware
    kern.timecounter.hardware: ACPI-fast
    


  • I haven't spent any time with pfsense just yet, just installed it today and skimmed over the web-interface for a minute or two. (wan-loadbalancing… yum yum!)

    I'll actually start setting it up tomorrow, if i encounter the time-issue you mentioned I'll know where to find a fix - thanks a lot in advance. ;)



  • @hoba:

    I had to set my box to the following timecounter-hardware to make it run without issues:

    $ sysctl kern.timecounter.hardware
    kern.timecounter.hardware: ACPI-fast
    

    This is my output of sysctl:

    kern.timecounter.hardware: TSC
    

    I've time-bugs too ???

    Mar 18 22:52:29 	kernel: pid 30765 (php), uid 0: exited on signal 6 (core dumped)
    Mar 18 22:14:47 	kernel: pid 24914 (php), uid 0: exited on signal 6 (core dumped)
    Mar 18 21:54:14 	kernel: pid 20963 (php), uid 0: exited on signal 6 (core dumped)
    Mar 18 21:25:00 	check_reload_status: check_reload_status is starting
    Mar 18 20:50:53 	dnsmasq[12221]: read /etc/hosts - 2 addresses
    

    My local time is 8:54PM now. Also I have and different measures in RRD Graphs - on WAN in 114.64MB, but on LAN out 129.43MB :o Maybe this is linked with time-bugs



  • Make sure that your bios version is the latest and greatest



  • @Darth_Potato:

    My local time is 8:54PM now. Also I have and different measures in RRD Graphs - on WAN in 114.64MB, but on LAN out 129.43MB :o Maybe this is linked with time-bugs

    Different Traffic between interfaces is normal. You have some traffic at WAN for example that will be blocked but that is seen from your WAN interface. Also some broadcasts that are seen at the LAN interface won't be routed out the WAN though they hit your LAN interface.

    Btw, this ACPI-fast is the setting that works on my IBM eserver x330 server. You probably don't have this counter at your system but maybe others. My server offers 3 timecounters but this is the one that I found out to work ok. Check what counters are available at your system and try all of them.


Log in to reply