Squid Guard Time Based ACL issues



  • Hey Guys…

    Having trouble with Squid Guard...

    I am using squidguard: 1.4_3 pkg v.1.9

    I can get group ACLS working and but it only works 1 way... so if my time is set to 17:20 - 17:30

    Block xxx sites before and allow between the time specified above it will only do the first chang i.e 17:20... but when 17:30 comes around the changes do not go back to blocked... I hope that makes sense.

    All tutorials and still no luck...
    I have been throu: http://diskatel.narod.ru/pfSense/doc/squidGuard/squidGuardQuick.htm

    I have specified both target times as well...

    Ummm i have disabled transparent proxy so i can monitor both https and http traffic...

    By my understanding common ACL settings are ignored if there is a group ACL Specified.

    I have simplified the settings as far as possible to avoid any other problems... thats why the settings are so simple in the images below...

    All help is greatly appreciated...









  • P.S. Here are more server setting. Not sure if this will help either…






  • If I understand correct than in Group-ACL the "Target Categories" is the time from 2030-1728 and the "target categories off time" is from 1728-2030

    So I would try with target categories:
    block_sites: deny
    white_list: whitelist
    default access: deny

    Target categories off time:
    block_sites: whitelist/deny
    white_list: whitelist
    default access: whitelist

    after this always do "Save" and then "apply" on "General settings" tab.



  • @Nachtfalke:

    If I understand correct than in Group-ACL the "Target Categories" is the time from 2030-1728 and the "target categories off time" is from 1728-2030

    So I would try with target categories:
    block_sites: deny
    white_list: whitelist
    default access: deny

    Target categories off time:
    block_sites: whitelist/deny
    white_list: whitelist
    default access: whitelist

    after this always do "Save" and then "apply" on "General settings" tab.

    Thanks man i will give it a try tomorrow…

    As its 22H00 here in ZA

    The times really are 09:00-13:00 and 14:00-16:30

    but for testing purposes before left work i changed them...



  • So I updated the firewall this morning from 1.2.3 to 2.0 and now the proxy is working 100%… Not sure what changed or anything but very happy with the new release.

    Thank you guys. Keep up the awesome work on a fantastic product.


Log in to reply