Adding static DHCP leases



  • I have a recurring problem adding static DHCP leases using "Services: DHCP: Edit static mapping" in the browser GUI:

    The first static lease I add always works fine, but any subsequent attempts fail and produce the following error message:

    The following input errors were detected:

    • This Hostname, IP or MAC address already exists.

    This is in spite of the fact that I do not enter any data in the hostname or IP fields. I clone the MAC and have confirmed that it's good. Also, it doesn't matter which MAC I enter - whichever is entered after the first is rejected in the aforementioned fashion.

    Nothing is written to the DHCP system log in connection to this event.

    This behavior has been consistent through several 1.01 snapshots, including the latest at the time of writing.

    I have searched the forum and the wiki for any mention of "static mapping" and the following post comes closest to what I'm dealing with, although I don't use MAC filtering like the poster in this case does:

    http://forum.pfsense.org/index.php/topic,3551.msg21743.html#msg21743

    If anyone knows what can be done about this I would be very grateful for an explanation.

    Also, many thanks for an excellent product!


    Firmware used:
    1.0.1-SNAPSHOT-03-08-2007
    built on Sun Mar 11 05:51:41 EDT 2007


    Hardware:
    Celeron M 410 1,46GHz
    2GB DDR2 PC6400



  • yeah, i think that it's basically counting 'blank' as a hostname. so you can only have one. I know it used to allow unlimited blank hostnames, but i don't know when it changed.



  • @simpat1zq:

    yeah, i think that it's basically counting 'blank' as a hostname. so you can only have one. I know it used to allow unlimited blank hostnames, but i don't know when it changed.

    Yep, that was it. When I entered hostnames for the subsequent static leases they went through just fine. Thanks a lot for your help!


Log in to reply