Config errors upgrading from snapshot to 2.0-RELEASE



  • 2.0-RELEASE (amd64)
    built on Wed Sep 14 09:15:10 EDT 2011
    Platform nanobsd (2g, vga)

    I just did a console/local file upgrade from the Sep 8 (approximately) snapshot and got some errors on the console after the restart:

    Warning: Cannot use a scalar value as an array in /etc/inc/config.console.inc on line 533

    This was followed by the interface selection dialogue, which wouldn't complete, and only produced errors like this:

    Warning: Invalid argument supplied foreach() in /etc/inc/xmlparse.inc on line 211
    0r 0r 0r 0r 0r

    **************** WARNING *******************

    Configuration could not be validated. A previous configuration was restored.

    The failed configuration file has been saved as /conf/config.xml.bad}

    done.

    This is a production system and I didn't have time to extract the bad config file or examine the situation in depth, so I pulled the CF card and flashed from new. After booting the fresh 2.0-RELEASE I uploaded my config and all appears well. My concern is that this might be an issue lurking in my config and could pop up again after the next reboot or upgrade. Any ideas what's going on here or what to expect?


  • Rebel Alliance Developer Netgate

    You'd normally see those kinds of messages if the entire config was tossed out, either it was corrupt, or contained international characters.

    If the same config worked on another CF, then I'd blame the old CF.



  • The same config worked on the same hardware right before the update. It also worked on the same hardware after doing a clean install of 2.0-RELEASE. The only obvious thing that changed besides the date of the build was that I flashed a vga-enabled image on a non-vga box.


Locked