Error while creating Traffic Shaping rules



  • Hello,
    Hopefully someone can point me to the right direction. First I've tried to shaping with simple configuration by using wizard - Single WAN, Multiple LAN (obviously I'm using the newest version of pfsense). I've used 1.2.3 but I've given up as version 2 is much better. Thank you guys for good job.

    Scenario 1 - HFSC
    In first scenario I've tried to put just 1 LAN and then everything was fine after I've finished with this configuration. Not many details for that as I wanted something simple in first place.
    Bandwidth WAN: 100 Mbps / 100Mbps
    Reserved 3 Mbps for VoIP
    5% for P2P
    And that was everything. Also when I've saved everything worked as expected.

    Scenario 2 - HFSC
    Now I'm trying the same with 1 WAN + 1 LAN + 1 DMZ. The same settings applied as for first scenario 1.
    After saving I've got an error which you can see below:

    There were error(s) loading the rules: bandwidth for qInternet higher than interface
    /tmp/rules.debug💯 errors in queue definition
    parent qInternet not found for qACK
    /tmp/rules.debug:101: errors in queue definition
    parent qInternet not found for qP2P
    /tmp/rules.debug:102: errors in queue definition
    parent qInternet not found for qVoIP
    /tmp/rules.debug:103: errors in queue definition
    parent qInternet not found for qOthersHigh
    /tmp/rules.debug:104: errors in queue definition
    parent qInternet not found for qOthersLow
    /tmp/rules.debug:105: errors in queue definition
    pfctl: Syntax error in config file: pf rules not loaded The line in question reads [100]:  queue qInternet on em1 bandwidth 100Mb hfsc (  ecn  , linkshare 100Mb  , upperlimit 100Mb  )  {  qACK,  qP2P,  qVoIP,  qOthersHigh,  qOthersLow  }

    Any help appreciate as I don't have a clue why it's happening.

    Thanks,
    Andre



  • Ignore me. There is always simple answer. DMZ port wasn't connected to anything. Once I plug the cable into the switch I could create rules without errors what I've mentioned in first post.
    Hopefully it will help someone.


Log in to reply