Warning: D-link DGE-530T sk0 'flapping' after upgrade to 2.0



  • I have a machine with the above listed card/interface, that has been running 1.2.3 happily for 3-4 years.
    Upon upgrading to 2.0 I started losing connectivity, sometimes for seconds, other times for hours. I finally
    tracked it down via dmesg:
    Littered with HUNDREDS of:

    sk0: link state changed to DOWN
    sk0: link state changed to UP
    sk0: link state changed to DOWN
    sk0: link state changed to UP

    dmesg | grep ^sk0 | grep "DOWN" | wc -l  = 528 !!

    At this point the box has no packages installed, it's a straight 2.0 (had squid a few other things installed, but removed during diags).

    Not wanting to blame pfsense, I changed the cable, changed the port, changed the link speed, changed the switch, and then changed the card.
    I happen to have several of these cards in hand, for giggles, I threw another in, and have the same issue. It's very intermittent.

    it can run for half a day without flapping, then randomly it does it a few times, or 50 times in the matter of minutes.

    I've sense taken the original card, and another new card, and tried it in a completely different system, at a different location, with a fresh/new 2.0 install
    and have the same issues.

    Strangely enough, I have a freebsd server, with a seemingly identical card (same model) that's ran everything from 6.0 up to its current 8.2 (with it having seen 8.0, and 8.1) and it's never had this issue.

    Anything else I can do to trouble shoot this? Otherwise anyone using this card, be warned.

    Symptoms:
    The card just stops responding. Luckily it's not my internet interface, but my lan interface, after rebooting the first/second time, then discovering what's going on, I logged in via console. pinging the interface ip works, but trying to ping something on the network fails, as does network to pfsenes.  Issuing  ifconfig sk0 down, then ifconfig sk0 up restored network access. I've been fighting with this for 3-4 days now. (Any changes result in it working for an extended period of time, ~8 hrs.. and then it just blows up)



  • No idea, but as another troubleshooting step, did you try a different model/make of ethernet card to see if the issue persists or stops?



  • Yeah, I have a craptastic realtek gige card in place, running for 11 hours, so far, not a single hiccup. I suspect its a driver regression or some such.



  • I have a similar problem with 2.0.

    However i am running Intel NIC's

    Even when booting up in the 2.0 installer EM0 and EM1 flap continuously. Installed 1.2.3 everything working and then tried an upgrade and the NICs continued to flap albiet reachable very intermittently.

    For reference dmesg output from the 1.2.3 running implementation.

    em0: <intel(r) 1000="" pro="" network="" connection="" 6.9.6="">port 0xc800-0xc81f mem 0xfe280000-0xfe29ffff,0xfe260000-0xfe27ffff irq 16 at device 0.0 on pci1

    em1: <intel(r) 1000="" pro="" network="" connection="" 6.9.6="">port 0xcc00-0xcc1f mem 0xfe2e0000-0xfe2fffff,0xfe2c0000-0xfe2dffff irq 17 at device 0.1 on pci1</intel(r)></intel(r)>



  • I now have a third box, that had the same dlink nic installed, same issues. so far three different sets of hardware (other then nic, I haven't looked to see if they are different revisions). This one happens to be a 1.2.3 upgrade that has been running for a few years as well.



  • I now have another box with a intel pro 100/s doing this same thing as well..

    Meh.



  • There must be something atypical you're using that's causing that. There are likely thousands of 2.0 installs with Intel NICs without issue. Somewhere around a year ago there were issues with bridging and the em driver where unplugging and replugging a NIC would lead to constant link cycling but that was fixed by updating the em driver and I haven't heard of any such issues since. Can you narrow it down to some unusual config you have on there?



  • I have had the SAME problems with the snapshots and the 2.x release ….its very random.

    it is not a switch issue, wire issue, and the only thing i can think of is a driver problem, but that said....i have tried four different NIC card makers and all of them have the same issue.

    link to my original post aboot this issue: http://forum.pfsense.org/index.php/topic,40147.msg207235.html#msg207235

    strangely enough the link does NOT stay down …its what i call a hiccup that isnt even noticed unless i do a constant ping for days upon days.


Locked