Unable to upgrade to the latest snapshot for pfSense-2.0-RELEASE?



  • hi there,
    I am running pfSense 2.0 RC3 with git snapshot on my router. When it released 2.0-RELEASE, I found I always got

    Downloading new version information…done
    Obtaining current version information...done

    You are on the latest version.

    on the Auto Update page. And in Updater Setting page, I can only choose "pfSense Stable Release Updates(i386)"( http://updates.pfsense.org/_updaters ) and "pfSense Stable Release Updates(amd64)" ( http://updates.pfsense.org/_updaters/amd64 ). Could you tell me how to keep in the latest development version? Thanks.



  • @jilingshu:

    hi there,
    I am running pfSense 2.0 RC3 with git snapshot on my router. When it released 2.0-RELEASE, I found I always got

    Downloading new version information…done
    Obtaining current version information...done

    You are on the latest version.

    on the Auto Update page. And in Updater Setting page, I can only choose "pfSense Stable Release Updates(i386)"( http://updates.pfsense.org/_updaters ) and "pfSense Stable Release Updates(amd64)" ( http://updates.pfsense.org/_updaters/amd64 ). Could you tell me how to keep in the latest development version? Thanks.

    Right now it seems that the snapshot options are off. There are no snapshots right now. So you will need to go to 2.0-Release and then gitsync from source to get the new source changes.



  • @podilarius:

    @jilingshu:

    hi there,
    I am running pfSense 2.0 RC3 with git snapshot on my router. When it released 2.0-RELEASE, I found I always got

    Downloading new version information…done
    Obtaining current version information...done

    You are on the latest version.

    on the Auto Update page. And in Updater Setting page, I can only choose "pfSense Stable Release Updates(i386)"( http://updates.pfsense.org/_updaters ) and "pfSense Stable Release Updates(amd64)" ( http://updates.pfsense.org/_updaters/amd64 ). Could you tell me how to keep in the latest development version? Thanks.

    But it always told me I'm on the latest version, no update option is available…

    Right now it seems that the snapshot options are off. There are no snapshots right now. So you will need to go to 2.0-Release and then gitsync from source to get the new source changes.



  • Upload a full 2.0 release tgz update to your box and then upgrade via console.

    Suggestion:
    Remove all packages before update.



  • @marcelloc:

    Upload a full 2.0 release tgz update to your box and then upgrade via console.

    Suggestion:
    Remove all packages before update.

    hi, do you mind telling me the way to "upgrade from console" ? Did you mean upgrade from the web console "System -> Firmware" ?



  • Enable ssh or go to routers serial console(if any).


  • Rebel Alliance Developer Netgate

    A manual upgrade in the GUI would work. Or do a console upgrade by URL and just enter "auto" and it will force it to download the newest firmware, and then apply your git code over the top.

    If you just want to update your code and not the binaries, you can use gitsync from the PHP shell or:

    pfSsh.php playback gitsync master
    


  • @jimp:

    A manual upgrade in the GUI would work. Or do a console upgrade by URL and just enter "auto" and it will force it to download the newest firmware, and then apply your git code over the top.

    If you just want to update your code and not the binaries, you can use gitsync from the PHP shell or:

    pfSsh.php playback gitsync master
    

    @Jimp I've been away for a bit but i also noticed that I can't update the binaries for my 2.1-Dev build. I updated my box with the 2.0 release bin then gitsync to 2.1 code.. Does this include the DHCPd security patch? Is the snapshots down because you are getting ready to move to FreeBSD 9 on pfSense 2.1?


  • Rebel Alliance Developer Netgate

    There have been no new snapshots or binaries since 2.0 released.

    The builds for 2.1 will be on 9.0 shortly, much work is happening there this week



  • Thanks Jimp!



  • @jimp:

    A manual upgrade in the GUI would work.

    Unfortunately, I found it does not work…
    After I select the upgrade file and click "Upgrade", whe web page has sucked and I can hear the hard disk driver running.
    But after 5 or more minutes, it still working and did not reboot. I can open another window to log in the web console and I can also ssh to it. What is strange is there are nothing special in the "ps" output and "top" also told me CPU load is less than 1%, however, my computer become very very slow after that. Each command I typed in ssh console would take several second to echo.
    I reboot it manually in ssh by choosing "5) Reboot system". After it rebooted, the webconsole still told me I am in 2.1-DEVELOPMENT.
    So I think the upgrade does not completed.
    However, I am trying to upgrade it via ssh console.


  • Rebel Alliance Developer Netgate

    If you are on 2.1-DEVELOPMENT then it will still say so after the upgrade. If you set the gitsync options that happens after a firmware update. So it would update the kernel and binaries but your code is also updated.

    You'd have to check the timestamp on the kernel (uname -a) to see if it's really updated.



  • @jimp:

    If you are on 2.1-DEVELOPMENT then it will still say so after the upgrade. If you set the gitsync options that happens after a firmware update. So it would update the kernel and binaries but your code is also updated.

    You'd have to check the timestamp on the kernel (uname -a) to see if it's really updated.

    hi,
    I have disabled auto gitsync function and it now become 2.0-RELEASE. Thanks!
    BTW: I am eager for 2.1-IPv6 beta released… Do u have any estimate roadmap?



  • @jilingshu:

    BTW: I am eager for 2.1-IPv6 beta released… Do u have any estimate roadmap?

    It's already released and been out for months, check the IPv6 board for info. Just have to gitsync 2.0 to it, no binary differences yet.



  • @cmb:

    @jilingshu:

    BTW: I am eager for 2.1-IPv6 beta released… Do u have any estimate roadmap?

    It's already released and been out for months, check the IPv6 board for info. Just have to gitsync 2.0 to it, no binary differences yet.

    hmmm…. I have already tried it and found there r so many bugs in those snapshots... Even some features which work well in 2.0-RELEASE are broken in 2.1-DEVELOPMENT such as Captive Portal... :-(



  • @jilingshu:

    hmmm…. I have already tried it and found there r so many bugs in those snapshots... Even some features which work well in 2.0-RELEASE are broken in 2.1-DEVELOPMENT such as Captive Portal... :-(

    Only thing that doesn't work in 2.1 is captive portal, everything else is little different except with IPv6 support, all works well.


Locked