ALTQ problem with "rl" interface



  • While the Filter Reload Status (after using the EZ Shaper wizard) I get the following error:

    There were error(s) loading the rules: pfctl: rl1: driver does not support altq - The line in question reads [ rl1]: ...
    

    But I have read in this forum, that ALTQ works with a rl interface. So where is the problem?

    I have a Jetway J7F4K1G2 with two Realtek RTL8110SC PCI LAN Chips and using this driver http://forum.pfsense.org/index.php/topic,2765.msg16564.html#msg16564



  • Can you test this with another model net card?



  • Perhaps that model of realtek does not support it.

    Either way you should consider dumping that sub-standard card and go with something a bit better such as intel.



  • @dvserg
    No :(

    I have just a Wlan card, which make even problems to run normaly…

    @sulrich

    I would use intel gladly, but the problem is, that it is a mini-itx board and in the one and only pci slot is the wlan card.

    In the thread about the driver stands

    The re(4) driver supports RealTek RTL8139C+, RTL8169, RTL8169S and
    RTL8110S based Fast Ethernet and Gigabit Ethernet adapters

    but I have a RTL8110SC. Could be this a problem?



  • @BlackNexxus:

    but I have a RTL8110SC. Could be this a problem?

    Very possibly.



  • Mmmh. Now I am confused.
    If I look in the FreeBSD Man Pages, I read that I need the re driver. At first gbelanger talked also about this driver. But in the end he compiled the rl driver.
    The driver I downloaded from Realtek seems to be a rl driver and I think it's the driver, which gbelanger used.
    Only an older version, but the new version added just "implement the interrupt handler of rx fifo overflow"

    I will install the whole system anew, because I think there was maybe an error during the last installation (very old cd-rom device), because I have some mysterious problems and for a few hours the system don't boot completly.
    Than I make a new test.



  • I just recently ran into this issue as well. I purchased an mini-itx system from Mini-Box with the 3 Gigabit Ethernet port add-on figuring it was going to work out great.

    Little did I know…

    The basic issue is the version of the drivers Realtek released doesn't support ALTQ, it makes calls to the interface directly instead of calling into the queue management functions. I suspect that the driver source they released was meant to be compatible with multiple versions of FreeBSD and the 4.x generation of FreeBSD didn't support ALTQ.

    I tried back porting the FreeBSD 6.2 driver source back to the pfsense 1.0.1/FreeBSD 6.1 environment which is supposed to support the new card IDs, but didn't have much luck. The system would hang after identifying the 2nd gigabit port, sometimes the third.

    I eventually settled on using pfSense 1.0.1/FreeBSD 6.1 with the Realtek drivers, I'm not sure when I'll give it another go.

    I am using a CF card to boot my mini-itx computer. My build environment was through Virtual PC 2007. I was basically uploading new CF images to an FTP server, PXE booting the mini-itx system using RIPLinix and then dd the image to the CF card. My CF reader on my Windows box was eating up CF cards (probably user error).

    ----- Rom



  • The new snapshots run freebsd 6.2. Did you try to run your box with these?



  • One of the variations I tried involved a recent snapshot.

    But I don't remember if it was a stock configuration or not. I was using a variation of the mkflash_new.sh script to modify the cf images to add different drivers and stuff. It took me awhile to get my barrings, it was my first time working with FreeBSD.

    BTW, I think there is a bug in the mkflash_new.sh script. Near the end of the script it tries to unmount the device instead of the directory which causes a file system check the very first time the machine is rebooted after writing the image to the CF disk. It isn't a huge deal since the file system check fixes the issue for future reboots.

    Original:
    cd $FLASHTMP
    umount /dev/${MD}a
    umount /dev/${MD}d
    echo "date '+%b %e %T': Cleanig up."

    Modified:
    cd $FLASHTMP
    umount mnt/a
    umount mnt/d
    echo "date '+%b %e %T': Cleaning up."


Log in to reply