PPPOE Wan testers needed



  • Please help test the most recent snapshot which features mpd4 (recent version mpd3) and ensure that everything still works like it used to (or better).



  • Not working for me… Czech O2 adsl

    Mar 13 08:13:41 mpd: AUTHPROTO PAP
    Mar 13 08:13:41 mpd: MAGICNUM e4d2eab7
    Mar 13 08:13:41 mpd: AuthGetData: empty auth name
    Mar 13 08:13:41 mpd: Warning: no secret for "" found
    Mar 13 08:13:41 mpd: MESG: Access-Request has to contain a User-Name.
    Mar 13 08:13:48 mpd: PPPoE: rec'd ACNAME "P10B03BRNOJA"
    Mar 13 08:13:48 mpd: MRU 1492
    Mar 13 08:13:48 mpd: MAGICNUM 98838a5a
    Mar 13 08:13:48 mpd: MRU 1492
    Mar 13 08:13:48 mpd: MAGICNUM 98838a5a
    Mar 13 08:13:50 mpd: MRU 1492
    Mar 13 08:13:50 mpd: MAGICNUM 98838a5a
    Mar 13 08:13:50 mpd: MRU 1492
    Mar 13 08:13:50 mpd: MAGICNUM 98838a5a
    Mar 13 08:13:52 mpd: MRU 1492
    Mar 13 08:13:52 mpd: MAGICNUM 98838a5a
    Mar 13 08:13:52 mpd: MRU 1492
    Mar 13 08:13:52 mpd: MAGICNUM 98838a5a
    Mar 13 08:13:53 mpd: MRU 1492
    Mar 13 08:13:53 mpd: AUTHPROTO PAP
    Mar 13 08:13:53 mpd: MAGICNUM e4d31683
    Mar 13 08:13:53 mpd: MRU 1492
    Mar 13 08:13:53 mpd: AUTHPROTO PAP
    Mar 13 08:13:53 mpd: MAGICNUM e4d31683
    Mar 13 08:13:53 mpd: AuthGetData: empty auth name
    Mar 13 08:13:53 mpd: Warning: no secret for "" found
    Mar 13 08:13:53 mpd: MESG: Access-Request has to contain a User-Name.
    Mar 13 08:13:58 mpd: PPPoE: rec'd ACNAME "P10B03BRNOJA"
    Mar 13 08:13:58 mpd: MRU 1492
    Mar 13 08:13:58 mpd: MAGICNUM 98c1c7f8
    Mar 13 08:13:58 mpd: MRU 1492
    Mar 13 08:13:58 mpd: MAGICNUM 98c1c7f8
    Mar 13 08:14:00 mpd: MRU 1492
    Mar 13 08:14:00 mpd: MAGICNUM 98c1c7f8
    Mar 13 08:14:00 mpd: MRU 1492
    Mar 13 08:14:00 mpd: MAGICNUM 98c1c7f8
    Mar 13 08:14:01 mpd: caught fatal signal term
    Mar 13 08:14:03 mpd: process 206 terminated
    Mar 13 08:14:04 mpd: process 947 started, version 4.1 (root@builder6.pfsense.com 19:38 12-Mar-2007)
    Mar 13 08:14:04 mpd: Label 'startup' not found
    Mar 13 08:14:04 mpd: mpd.conf:8: Unknown command: 'set bundle authname'. Try "help".
    Mar 13 08:14:04 mpd: mpd.conf:9: Unknown command: 'set bundle password'. Try "help".
    Mar 13 08:14:36 dnsmasq[381]: exiting on receipt of SIGTERM
    Mar 13 08:14:37 dnsmasq[981]: started, version 2.36 cachesize 150
    Mar 13 08:14:37 dnsmasq[981]: compile time options: IPv6 GNU-getopt ISC-leasefile no-DBus no-I18N
    Mar 13 08:14:37 dnsmasq[981]: no servers found in /etc/resolv.conf, will retry
    Mar 13 08:14:37 dnsmasq[981]: no servers found in /etc/resolv.conf, will retry
    Mar 13 08:14:37 dnsmasq[981]: read /etc/hosts - 2 addresses
    Mar 13 08:14:38 check_reload_status: reloading filter
    Mar 13 08:14:44 check_reload_status: reloading filter



  • not working for me either, earlier snapshots ran just fine;

    MESG: Authorization failed
    Warning: no secret for "" found
    AuthGetData: empty auth name
    MAGICNUM 4eec4b37
    MRU 1492
    AUTHPROTO PAP
    MAGICNUM 1a5c957c
    MRU 1492
    AUTHPROTO PAP
    MAGICNUM 1a5c957c
    MRU 1492
    MAGICNUM 4eec4b37
    MRU 1492
    MESG: Authorization failed
    Warning: no secret for "" found
    AuthGetData: empty auth name
    MAGICNUM 516fb8dc
    MRU 1492
    AUTHPROTO PAP
    MAGICNUM 700e2afa
    MRU 1492
    AUTHPROTO PAP
    MAGICNUM 700e2afa
    MRU 1492
    MAGICNUM 516fb8dc
    MRU 1492
    MESG: Authorization failed
    Warning: no secret for "" found
    AuthGetData: empty auth name
    MAGICNUM 515724c6

    … and so on.



  • Polish ISP TPSA, ADSL Neostrada service

    Mar 13 14:15:53 mpd: Warning: no secret for "gda_ru3" found
    Mar 13 14:15:58 mpd: Name: "gda_ru3"
    Mar 13 14:15:58 mpd: Using authname "gda_ru3"
    Mar 13 14:15:58 mpd: OpenConfFile: Can't open file '/var/etc/mpd.secret': No such file or directory
    Mar 13 14:15:58 mpd: Warning: no secret for "gda_ru3" found
    Mar 13 14:16:06 mpd: PPPoE: rec'd ACNAME "Neostrada"
    Mar 13 14:16:06 mpd: MRU 1492
    Mar 13 14:16:06 mpd: MAGICNUM ac51a570
    Mar 13 14:16:06 mpd: MRU 1492
    Mar 13 14:16:06 mpd: AUTHPROTO CHAP MD5
    Mar 13 14:16:06 mpd: MAGICNUM 62c63561
    Mar 13 14:16:06 mpd: MRU 1492
    Mar 13 14:16:06 mpd: AUTHPROTO CHAP MD5
    Mar 13 14:16:06 mpd: MAGICNUM 62c63561
    Mar 13 14:16:06 mpd: MRU 1492
    Mar 13 14:16:06 mpd: MAGICNUM ac51a570
    Mar 13 14:16:06 mpd: Name: "gda_ru3"
    Mar 13 14:16:06 mpd: Using authname "gda_ru3"
    Mar 13 14:16:06 mpd: OpenConfFile: Can't open file '/var/etc/mpd.secret': No such file or directory

    and so on…

    recent snapshots worked OK (eg. 27.02.07).

    gda_ru3 is not my authname, it is a name of the router/server on ISP side. Strange.

    Below goes log from working version:

    Mar 13 14:24:06 mpd: mpd: pid 201, version 3.18 (root@builder6.pfsense.com 13:56 13-Feb-2007)
    Mar 13 14:25:01 mpd: MRU 1492
    Mar 13 14:25:01 mpd: MAGICNUM d85dc9dd
    Mar 13 14:25:01 mpd: MRU 1492
    Mar 13 14:25:01 mpd: AUTHPROTO CHAP MD5
    Mar 13 14:25:01 mpd: MAGICNUM 35cdf52e
    Mar 13 14:25:01 mpd: MRU 1492
    Mar 13 14:25:01 mpd: AUTHPROTO CHAP MD5
    Mar 13 14:25:01 mpd: MAGICNUM 35cdf52e
    Mar 13 14:25:01 mpd: MRU 1492
    Mar 13 14:25:01 mpd: MAGICNUM d85dc9dd
    Mar 13 14:25:01 mpd: Name: "gda_ru3"
    Mar 13 14:25:01 mpd: Using authname "Eyd7rLK@neostrada.pl"
    Mar 13 14:25:02 mpd: IPADDR 0.0.0.0
    Mar 13 14:25:02 mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Mar 13 14:25:02 mpd: COMPPROTO VJCOMP, 16 comp. channels, no comp-cid
    Mar 13 14:25:02 mpd: IPADDR 0.0.0.0
    Mar 13 14:25:02 mpd: IPADDR 83.25.4.137
    Mar 13 14:25:02 mpd: 83.25.4.137 is OK
    Mar 13 14:25:02 mpd: IPADDR 83.25.4.137
    Mar 13 14:25:02 mpd: IPADDR 83.25.4.137
    Mar 13 14:25:02 mpd: IPADDR 213.25.2.61
    Mar 13 14:25:02 mpd: 213.25.2.61 is OK
    Mar 13 14:25:02 mpd: IPADDR 213.25.2.61
    Mar 13 14:25:02 mpd: 83.25.4.137 -> 213.25.2.61



  • looks like they chanched the config of mpd in the version 4 of mpd
    mpd.secret was not used in version 3
    they used username and ww in the config

    make a file /var/etc/mpd.secret

    put in it youre username as in the mpd.config then a tab and then between " youre password

    so if i have
    set auth authname jeroen234
    in mpd.config and my pasword is 12345
    then in mpd.secret i have to put this
    jeroen234              "12345"

    (don't have adsl here but cable so i can't test this)



  • Yeah, I have reverted back to mpd3 until we can fix the issue.

    Thanks to everyone that tested.



  • I tryed to create that file but couldn't manage to get it to work



  • how do I roll back



  • wait 1 uhr or so
    then the buildserver will have made a new snapshot with the old mpd version
    that you then can download as a snapshot



  • will it come up as a different snap shot version?



  • No, you have to look at the date of the file, not the version number.



  • It's all sorted thanks. I have my system working now



  • I presume that this may need testing again shortly?



  • @Jonb:

    I presume that this may need testing again shortly?

    I don't plan on messing with mpd4 again until after 1.0.2 comes out.  We have enough drama to contend with currently.



  • Ok then I won't expect a change till then.  Just wanted to know incase it broke after an update.


Log in to reply