Tinydns setup + resolution



  • Hi,

    I'm very new in DNS at practice. I use Pfsense 2.0 + tinydns package. I have running a samba server as PDC on a different machine and I also want DNS for it on pfsense.

    So my net looks like that
                             Samba Server 192.168.1.200 workgroup = foo.intern
    int. 192.168.1.1  /
    pfsense <–---  192.168.1.0/24
                           
                             Clients

    My domain is foo.intern
    pfsense host: mcp
    Tinydns is binded at 127.0.0.1 and is listen on all NICs

    tinydns data, created with the wizard

    .foo.intern::ns.foo.intern.:30
    +foo.intern:192.168.1.1:30

    resolv.conf
    domain foo.intern
    nameserver 127.0.0.1
    nameserver 192.168.1.1
    nameserver 172.16.23.1 <--ISP DNS

    dns forwarder activated
    no dnscache
    the only thing which works is, ping mcp.foo.intern from all my clients but I cant reach any client hostnames.

    Thanks



  • I have also a lot of problems getting DNScache to work, but TinyDNS seems to work fine for me if changing the Bind Address to the internal one.



  • I cannot get this thing to work.

    My config:
    Binding to 127.0.0.1
    Interface to listen: all
    Enable recursive DNS responder: ON
    Zone transfers: 127.0.0.1

    When I try nslookup google.com 127.0.0.1, I get:
    Server:        127.0.0.1
    Address:        127.0.0.1#53

    Non-authoritative answer:
    *** Can't find google.com: No answer

    On log I get:
    2011-11-05 14:47:31.238454500        0.0.0.0:9673 A        responded                google.com

    Please help!



  • If I take off: Enable recursive DNS responder, then on my log I get:

    2011-11-05 15:25:38.152130500         0.0.0.0:4055 A        not_authority            www.google.com

    Besides, my resolv.conf gets edited everytime I reboot/restart the server, where I stop that (script) ?



  • Solved.



  • For future use it would be great if you could type down the solution for us to view.


Locked