Nut package gone?



  • I went to try out the NUT package for UPS triggered shutdown on a box and the installation failed. I saw that there were a few issues with some of the snapshots, so I updated to the latest snap. Still no NUT. I can install other packages, so it appears the package is missing/removed? Checking /tmp I find a 0 byte apkg_nut-2.0.5.tbz. The log shows    [0] => tar: Error opening archive: Empty input file: Inappropriate file type or format (sounds about right as there is nothing in the file…) A manual scan of http://www.pfsense.com/packages/All/ does not find the file. (I don't really know if  that is even the correct place it should be)



  • The nut port was probably updated to a new version. I'm actually on vacation this week and then I can look into it. The wireless internet here is horrible (1000ms ping times) and its hard enough just to check my email and a few threads on the forums.

    EDIT:

    Nut should be working now. I was able to get ssh to connect and updated the link to the nut port.



  • Thanks for getting the package back up. Sorry to intrude on your vacation. I Got it running on a test box today with an APC smart-ups. Serial on com2 was flawless, usb worked, but kept disconnecting/reconnecting. I suppose that's an issue between NUT and the FreeBSD usb driver. That or the usb ports on the old crappy test box I was using. The service came up broken after it restarted (when I plugged the ups back in) and I had to re-install the package, but I think that may mean I need to be rebuild my test box. I'll try it on the production box as soon as I can get a ups close enough for the cable to reach. Thanks again for your work on the package.



  • No problem at all .. only took a few minutes to fix once I got ssh working. Anyways I've heard from somebody else as well about the problem with nut not starting upon a reboot. I will look into this. They had mentioned that going to the nut configuration page and clicking change started nut.



  • that's correct :-)

    it was me :-)

    http://forum.pfsense.org/index.php/topic,4063.0.html
    just opened this thread… for the same problem and the question for pfsense shutdown issues...

    Can I configure pfsenses shutdown behaviour when USV goes down or does NUT send a "halt" to pfsense then ?
    Or anything to configure anywhere ?



  • I believe the default shutdown command (which worked fine on my box) is in /usr/local/etc/nut/upsmon.conf (SHUTDOWNCMD "/sbin/shutdown -h +0") you could probably manually edit that if you needed. I was looking for the shutdown timer (I use apcupsd on some of my systems) but reading the NUT docs it seems the philosophy of the NUT author is to keeps the system up until battery is critical and power is off. In testing this was around 15% for me.



  • I just committed an update to nut that should fix it not starting upon a reboot. Please reinstall the package, goto the nut settings page click change, then reboot and let me know if it works for you.



  • i'll try it out after i slept out :-)

    thanks a lot !



  • hmmm, not really working here for me :-(



  • @trendchiller:

    hmmm, not really working here for me :-(

    What did the nut status page show after your restarted?

    Restart your box and run

    /usr/local/etc/rc.d/nut.sh start

    from the console and let me know the output. The problem I corrected dealt with permissions /dev/ttyd* depending on your serial port permissions being reset.



  • Hmmm, after a reinstall of pfsense it seems to work now…

    will furthermore have a look after it...

    thanks a lot



  • Got a chance to test this again. I had similar results to trendchiller on my test box- service wasn't starting after upgrading the package, but did a clean load and added the package fresh and it looks good. Thanks rsw for getting this package running smoothly.


Log in to reply