PfSense 2.0 is taking a long time to react to ARP replies.



  • I want to post this here before I go to redmine to file a bug. Maybe something is wrong with my configuration. Basically, I have arp responses coming in on a vlan interface, but pfSense doesn't add an entry to its arp table corresponding to the arp reply until quite a long time has elapsed.

    If on pfSense I run "ping 10.0.22.23", a packet capture shows

    Who has 10.0.22.23? Tell 10.0.22.3
    10.0.22.23 is at x❌x❌x:x (the x's are really hex numbers, naturally)

    I see this sequence 10+ times until I finally see
    Echo (ping) reply

    This isn't host specific, although both of the hosts I've tried are running Debian Lenny.

    My configuration is quite complicated. I can post any details. I have 9 VLANs on bge0, and those are the only interfaces in use.

    Jeff

    PS I've only noticed this problem only on one vlan interface. It has a static IP address and no gateway. I don't think there's anything special about it. It doesn't have any gateways or routes assigned to it.



  • you have other VLANs that work fine? Where are you seeing that ARP, on the VLAN interface itself or the parent? May also want to check the parent with -e on tcpdump to ensure those have the correct VLAN tag from the switch.


Locked