Bind 9 Start Server Error updated to version 2 clean install



  • Hi there,

    I am trying to get Bind v98 working on pfSense.

    What I have done is taken the tutorial here:
    http://doc.pfsense.org/index.php/Creating_a_DNS_Black_Hole_for_Captive_Portal_Clients

    Then looked in the list of applications/services and found this link here:
    ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/bind98.tbz

    I then ran this command here:

    pkg_add -r ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-current/Latest/bind98.tbz

    As per the tutorials ran through every single config in the tutorial (and I mean every one of them), worked before when I went up to Bind v9.8 (which is what this relates to), got pfSense working for a dns server using Bind 9.8 on pfSense version 1.2.3

    But I now have upgraded to v2 and it keeps bringing up this annoying error:

    /libexec/ld-elf.so.1: Shared object "libgssapi_krb5.so.10" not found, required by "named"

    When I run:

    named -u bind

    As per the tutorials anyone got any kind of suggestions on how I can obtain this package that has this dependency?

    Would very much appreciate some help with this matter, or I shall have to go back to v1.2.3 at least that version of Bind worked.

    Any helps much appreciated!

    Jeremy



  • I will have another go if I get the time.

    But I have migrated this over to my actual server for now, just changed the IPs in my forwarder, pfsense v2 is allot faster though, always wondered what was bugging down my internet speeds and that was the culprit v1.2.3 was just horrendously slow to the point I would get really annoyed!

    But no it's great thanks for that but any feedbacks very much appreciated!

    Jeremy.


Locked