ALIX embedded 1.2.3 upgrade to 2.0 release: problems



  • I upgraded my ALIX box from 1.2.3 to the 2.0 release version yesterday - I have a 4Gb CF card so I loaded the pfSense-2.0-RELEASE-4g-i386-nanobsd-upgrade.img.gz image. Everything seems to have worked fine except that the RDD graphs are not working and display "There has been an error creating the graphs. Please check your systemlogs for further details" (attached picture).

    The system log contains errors like this:

    php: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: No DS called 'inpass' in '/var/db/rrd/wan-traffic.rrd'/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/wan-traffic.rrd-4year.png –start 1191076318 --end 1317565918 --vertical-label "bits/sec" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "hostname - WAN :: Traffic - 4 years - 1 day average" --height 200 --width 620 DEF:wan-in_bytes_pass=/var/db/rrd/wan-traffic.rrd:inpass:AVERAGE DEF:wan-out_bytes_pass=/var/db/rrd/wan-traffic.rrd:outpass:AVERAGE DEF:wan-in_bytes_block=/var/db/rrd/wan-traffic.rrd:inblock:AVERAGE DEF:wan-out_bytes_block=/var/db/rrd/wan-traffic.rrd:outblock:AVERAGE CDEF:"wan-in_bits_pass=wan-in_bytes_pass,8," CDEF:"wan-out_bits_pass=wan-out_bytes_pass,8," CDEF:"wan-in_bits_block=wan-in_bytes_block,8," CDEF:"wan-out_bits_block=wan-out_bytes_block,8," CDEF:"wan-in_bytes=wan-in_bytes_pass,wan-in_bytes_block,+" CDEF:"wan-out_bytes=wan-out_bytes_pass,wan-out_bytes_block,+

    Can anyone suggest what I can do to fix this?




  • It seems that the RDD graphs are OK - system graph shows up just fine.

    The problem is specific to the graphs that display traffic, packets etc from the interfaces.  Although the ALIX box is passing packets through the interfaces, there's no way to configure the interfaces - the "Interfaces:LAN | WAN" menus all display a box to "enable" the interface (the box is checked) but nothing else.

    I'm guessing the next step is to try and reset the box to the factory defaults unless someone has a better idea?



  • You don't need to reset the entire box, just reset the graphs, that should fix it.



  • @Jason:

    You don't need to reset the entire box, just reset the graphs, that should fix it.

    Thanks for the reply - it seems that the problem was related to a bridge that I'd setup on 1.2.3 between the WLAN and LAN - removing the bridge has fixed all of the problems and the interfaces all look normal with the RDD graphs appearing as expected.  Setting up a bridge had been a hack originally to try and get shared WLAN and LAN access to some media stuff that had never worked properly originally and I (stupidly) had forgotten about it.  I'll chalk this up to "user error"



  • One other "failure to migrate" occurred during the upgrade - my WAN interface is PPPoE into a DSL modem (AT&T DSL) and was set to periodically reset every 24 hours to get a new IP address.

    After upgrading to 2.0 the periodic reset settings were lost.


Locked