Traffic shaper errors after 1.2.3 to 2.0 upgrade



  • Hi All,

    I'm having trouble setting up a traffic shaper rule to limit a VPN tunnel to 2Mbit.
    It worked fine in 1.2.3 with a shaping rule to penalize an IP and thus limit it to 2Mbit.
    After upgrading in place to 2.0 release, the traffic shaper is empty, so I'm trying to set up a new one using the wizard: single LAN, multiple WAN.
    We have a 20Mbit synchronous WAN and I've set up an IPsec tunnel for Netbios and SMB traffic with a remote location.

    I've run the traffic shaper wizzard "Single LAN, Multi WAN" with the following settings:
    -Number of WAN connections: 1

    • Download Scheduler: HFSC
    • Upload Scheduler: HFSC
    • Connection upload / download: 20Mbit

    VoIP: disabled

    Penalty Box: enabled

    • Address: IP of local VPN endpoint
    • Bandwidth: 10% (won't allow me to enter 2Mbit, only a percentage)

    All the other wizard pages are left disabled.

    After finishing the Traffic Shaper wizard the filter reload page outputs the following error messages:
    There were error(s) loading the rules: bandwidth for qInternet higher than interface
    /tmp/rules.debug:51: errors in queue definition
    parent qInternet not found for qACK
    /tmp/rules.debug:52: errors in queue definition
    pfctl: Syntax error in config file: pf rules not loaded The line in question reads [51]:  queue qInternet on le0 bandwidth 20971.52Kb hfsc (  ecn  , linkshare 20971.52Kb  , upperlimit 20971.52Kb  )  {  qACK  }

    I've also tried to set it up using PRIQ instead of HFSC, which doesn't give any errors, but also doesn't limit the traffic.

    Does anybody have an idea why the wizard would generate a rule set that results is this error?

    Thanks in advance for any pointers.

    Wim.


Locked