DHCP & IPv6 Error Log Problem



  • Hello guys, I have some weird error in my DHCP log in PFsense. I believe it has to do with my IPv6 routing. I have 3 subnets setup. LAN uses 192.168.1.x, WLAN uses 192.168.2.x, & DMZ uses 192.168.3.x. The error in the log has to do with IPv6 & my server on my DMZ which is IP 192.168.3.2.

    I used the IPv6 guide on the pfsense docs website but also had to use another linux/unix IPv6 guide to figure out how to adapt tunnelbroker.net service to work with pfsense on multiple subnets. I got my LAN setup working perfectly per the PFsense guide. I then had my DMZ (server) using IPv6 perfectly to. Now it suddenly has broke & I see the error log filled with this stuff.

    Can anyone tell me what the error log is trying to say, & how to fix it? I think fixing this error may fix my IPv6 connectivity on my server.
    [DHCP Error Log.txt](/public/imported_attachments/1/DHCP Error Log.txt)



  • You have a connection error: em0, em1 and em2 are connected together:

    Oct 4 17:03:14 dhcpd: DHCPREQUEST for 192.168.3.2 from 00:07:e9:10:75:4a via em2: wrong network.

    Oct 4 17:03:14 dhcpd: DHCPNAK on 192.168.3.2 to 00:07:e9:10:75:4a via em2

    Oct 4 17:03:15 dhcpd: DHCPREQUEST for 192.168.3.2 from 00:07:e9:10:75:4a via em1

    Oct 4 17:03:15 dhcpd: DHCPACK on 192.168.3.2 to 00:07:e9:10:75:4a via em1

    Oct 4 17:03:15 dhcpd: DHCPREQUEST for 192.168.3.2 from 00:07:e9:10:75:4a via em0: wrong network.

    Note that em0, em1 and em2 are all receiving a DHCP request from the same MAC address. It appears em1 has network 192.168.3.0/24 so DHCP requests for 192.168.3.2 on em0 and em2 will fail because em0 and em2 don't have network 192.168.3.0/24.

    It is not obvious to me that this has anything to do with IPv6.


Locked