After 1.2.3 -> 2.0 upgrade CPU usage showing only "Updating in 10 seconds"



  • On 3 hardware pfSense boxes - after upgrading from 1.2.3 to 2.0 CPU usage is not updating (messsage shows only "Updating in 10 seconds"). Another minor bug is that after upgrade on all OpenVPN channels "Compression" is checked.

    How can I get CPU usage working? RRD Graphs for Processor works.



  • I Also have this same bug, Any ideas please?
    thanks
    jak


  • Rebel Alliance Developer Netgate

    Look in /usr/local/www/javascript/index/ - do you have sajax.js and ajax.js there? If so, remove /usr/local/www/javascript/index/sajax.js

    That file is in the obsolete files list so it should be getting removed, but in some cases it's either not going away or it's coming back.



  • @jimp:

    Look in /usr/local/www/javascript/index/ - do you have sajax.js and ajax.js there? If so, remove /usr/local/www/javascript/index/sajax.js

    That file is in the obsolete files list so it should be getting removed, but in some cases it's either not going away or it's coming back.

    Hi Jimp,
    Ive deleted the file sajax.js and its now working again,
    I then rebooted my box and its still working, and the file sajax.js has not returned,
    Thank you Very much for your help  :)



  • @jimp:

    Look in /usr/local/www/javascript/index/ - do you have sajax.js and ajax.js there? If so, remove /usr/local/www/javascript/index/sajax.js

    That file is in the obsolete files list so it should be getting removed, but in some cases it's either not going away or it's coming back.

    Both of my 1.2.3->2.0 boxes at work had the sajax.js file.  Deleting it made the CPU meter work, thanks!


  • Rebel Alliance Developer Netgate

    I added that to the doc wiki as an faq this morning… wish I knew why it wasn't going away, since it's in the obsolete files list and should be removed automatically by the upgrade process. Were you perhaps running the Dashboard package on 1.2.3?



  • @jimp:

    I added that to the doc wiki as an faq this morning… wish I knew why it wasn't going away, since it's in the obsolete files list and should be removed automatically by the upgrade process. Were you perhaps running the Dashboard package on 1.2.3?

    Nope.


Log in to reply