CARP Setup working - Automatic NAT = OK; Manual NAT = Failing…



  • I've got a normal CARP setup which works "normally" - if i power down / kill the master router then it falls back with minimal/no loss of service however once I turn on Manual NAT so I can have the outbound source address set to the Virtual floating IP of the CARP interface and then fail over a box it goes haywire with massive (upto 50%) loss.

    When I turn on the manual outbound NAT there is 6 rules generated. These are:

    • localhost to wan

    • localhost to wan port 500 (Static)

    • pfsync to wan

    • pfsync to wan port 500 (Static)

    • lan to wan

    • lan to wan port 500 (Static)

    I've tried with removing various combinations of rules in case any were interfering, and have also tried using static ports but I still experience the loss, and am now at a total "loss" of what to do (pun not intended :/ ).
    This is running 2.0-release.



  • Wait some seconds until your switch flush mac address table.

    Also connect to your switch and see if there is any problem with mac table(full) or cpu usage.


Log in to reply