Unbound on 2.1-AMD64 broken



  • Hi!

    Beginning package installation for Unbound .
    Downloading package configuration file... done.
    Saving updated package information... done.
    Downloading Unbound and its dependencies... 
    Checking for package installation... 
     Downloading http://files.pfsense.org/packages/amd64/8/All/unbound-1.4.13-i386.pbi ...  could not download from there or http://ftp2.FreeBSD.org/pub/FreeBSD/ports/amd64/packages-8.1-release/All/unbound-1.4.13-i386.pbi.
    of unbound-1.4.13-i386 failed!
    
    Installation aborted.Backing up libraries... 
    Removing package...
    ...
    
    

    I do not fully understand what the bug is, if the URL is, whether the absence of ".pbi" in the repository AMD64. And why I386 to AMD64?

    pkg_config.8.xml.amd64:

    
    ...
    <depends_on_package_pbi>unbound-1.4.13-i386.pbi</depends_on_package_pbi>
    <depends_on_package_base_url>http://files.pfsense.org/packages/amd64/8/All/</depends_on_package_base_url>
    ...
    
    


  • Looks like this fella is having the same issue you are.

    I really don't think this has anything to do with IPv6 support, I think probably for whatever reason, yesterday the package repo for Unbound was just down or we all happen to catch it at the wrong time while something was being updated. Because while I didn't have this exact error, I did bomb an Unbound upgrade yesterday that required me to uninstall the package entirely.

    Not sure what all the options available to you as OP are, but if you can, you may want to move this to the package forum…



  • I think that is the problem of 2.1, because package system pbi_* only appeared in 2.1, and a special forum thread yet.

    The pfSense package installer as a result of parsing pkg_config.8.xml.amd64 refers to a nonexistent file.
    Maybe it's because of the lack```
    <build_port_path>/usr/ports/dns/unbound</build_port_path>



  • same issue on i386 embedded



  • Hi guys,

    I'm seeing the same thing here on an 2.1-ipv6 AMD64 box.

    Has there been a solution found for this yet?

    -Will



  • Just attempt to remind that a problem doesn't solved yet :(



  • Unbound integration into 2.1 is a ongoing project.


Log in to reply