Alix 2d13 / pfsense 2.0 / ide hdd / boot loader



  • Hy.

    i am trying to install pfsense full to a ide harddisk for an Alix 2d13 board.

    My procedure:

    1. install via live CD on a PC pfsense 2.0
    2. install the embedded kernel
    3. restart via live CD
    4. insert 'hw.ata.ata_dma="0" ' in /boot/loader.conf
    5. edit /etc/fstab => change da0 to ad0
    6. plug the IDE drive into the alix board
    7. first start up works, but after a shutdown, the alix board wouldnt boot anymore:
    
    F1   FreeBSD
    
    Boot:   F1
    Not ufs
    Not ufs
    No /boot/loader
    
    FreeBSD/i386 boot
    Default: 0:ad(0,a)/boot/kernel/kernel
    boot:
    
    

    i tryied also:

    boot0cfg -o packet -B -m 0xf da0
    
    boot0cfg -B -o nopacket,noupdate -b /boot/boot0sio -s 1 -t 1 ad4
    
    chflags schg /mnt/boot/kernel
    

    and i tried pfsense 1.2.3 also, but still the same problem… :(

    i need help please...
    any suggestions?

    best regards
    andi



  • Hey!

    What partitions do you have on your hdd?
    Or do you have a running system in the meanwhile?


Log in to reply