Freeradius disconect issue using gui



  • Hi all, i have an issue disconecting freeradius user using status->captive portal , the user is deleted of firewall but not of the freeradius online user, you can view using radwho command.
    Here are an example.

    1. The user "test" login succesfully and this is the "start" accounting message:
    Sat Oct  8 08:41:20 2011
            NAS-IP-Address = 190.X.X.X
            NAS-Identifier = "firewall01.localdomain"
            User-Name = "test"
            Acct-Status-Type = Start
            Acct-Authentic = RADIUS
            Service-Type = Login-User
            NAS-Port-Type = Ethernet
            NAS-Port = 10
            Acct-Session-Id = "7fdfeb5709d66d4a"
            Framed-IP-Address = 192.168.1.103
            Called-Station-Id = "deleted by me"
            Calling-Station-Id = "00:26:b6:00:00:00"
            Client-IP-Address = 190.X.X.X
            Acct-Unique-Session-Id = "a4a5911c36753cab"
            Timestamp = 1318081280

    Pls look the Acct-Session-Id in bold

    But in the radwho command show this:
    User-Name = "test"
    Acct-Session-Id = "09d66d4a"
    NAS-IP-Address = 190.X.X.X
    NAS-Port = 10
    Service-type = Login-User
    Framed-IP-Address = 192.168.1.103
    Acct-Session-Time = 642
    Calling-Station-Id = "00:06:b6:00:00"

    2.  I have to send the radzap command via cli for the user have to be disconected., Because using the gui is not working, and this is because using gui not have sending the correct Acct-Session-Id..

    Example:
    #radzap -u test $NAS-IP-Address $share-secret

    Sorry for my bad english…


Locked