NUT update? >2.4.2 [SOLVED… Ugly? Stupid way?]



  • Hello!

    I've got a hp T750 INTL which in snot recognized by the current NUT. I've tried many things :)

    Now, when I googled for freeBSD and my UPS I found this:

    Release notes for NUT 2.4.2 - what's new since 2.4.1:

    • the general USB support has been vastly improved, including many bug
        fixes, better OS support, new features and devices.

    • NUT now talks to Solar Controller Devices with the new ivtscd driver.

    • the snmp-ups driver supports more PDU, with a smaller disk footprint.

    • apcsmart supports more older SmartUPS and Matrix units.

    • the bestfortress driver is resurrected.

    • the virtual driver has been renamed to 'clone'.

    • the netxml-ups driver has received some care.

    • various debugging and development improvements have been done, around
        driver output; dummy-ups with more interaction and scripting and the
        device-recorder.sh script.

    • the build system has received many bugfixes and improvements.

    • the UPower (previously known as DeviceKit-power) rules file is now
        generated by NUT.

    • support for new devices: Apollo 1000A and 1000F; various Baytech RPC; old
        Best Power Fortress; Cyber Power Systems PR3000E, CP 1500C and OR2200LCDRM2U;
        all the new Dell UPS range (serial, USB and network); Eaton E Series NV and
        DX UPS, and Powerware 9130; older HP T500 and T750, newer T750 INTL (USB) and
        R1500 G2 (serial); Inform Informer Compact 1000VA; many serial and USB
        devices from Ippon, like Back Comfo Pro, Smart Power Pro and Smart Winner;
        IVT SCD series; Liebert GXT2-3000RT230 and PowerSure PSA; Mustek PowerMust
        424 / 636 / 848 USB; all new PowerCOM USB devices with HID PDC interface;
        Tripp-Lite INTERNETOFFICE700, SMART700USB and ECO550UPS; UPSonic DS-800
        (USB).

    Any chance that the NUT-package is getting to this version >2.4.2?



  • Some more info on the UPS

    [2.0-RELEASE][admin@pfnatte.home.n23]/root(5): usbconfig -u 0 -a 2 dump_device_desc
    ugen0.2: <t750 intl="" hewlett-packard="">at usbus0, cfg=0 md=HOST spd=LOW (1.5Mbps) pwr=ON
    
      bLength = 0x0012
      bDescriptorType = 0x0001
      bcdUSB = 0x0110
      bDeviceClass = 0x0000
      bDeviceSubClass = 0x0000
      bDeviceProtocol = 0x0000
      bMaxPacketSize0 = 0x0008
      idVendor = 0x03f0
      idProduct = 0x1f06
      bcdDevice = 0x0000
      iManufacturer = 0x0004  <hewlett-packard>iProduct = 0x0024  <t750 intl =""  ="">iSerialNumber = 0x0032  <2CJ7520310>
      bNumConfigurations = 0x0001</t750></hewlett-packard></t750> 
    

    If I want to help / try to update this package myself. Possible? Who's ported this/made a package of it to begin with?

    /iorx



  • Here I am talking to myself again…

    I've done, probably, something incredible stupid and needs to be stopped  :o Curiosity killed the cat they say.

    My hp 750 INTL UPS is recognized!

    This is what I did:

    • Downloaded this ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-9-current/Latest/nut.tbz

    • Extracted "usbhid-ups", "upsdrvctl" and put them in /usr/local/libexec/nut (and chmod)

    • Tried to start it with "./nut.sh start"… WOW! It started. (tried this with 8.2 nut.tbz... first. Didn't work)

    • pfsense GUI report NUT as running. NUT reports 31% load and allot of more data.

    As you probably understand I doesn't have a clue what I doing here :) What the above means for stability or other side effect on pfsense it out of my knowledge.

    So, if you know better. Please tell me if I should revert my changes if there is a risk that my pfsense box will "explode" or something.

    Brgs,
    iorx

    ![2011-10-10 00-12-05.png](/public/imported_attachments/1/2011-10-10 00-12-05.png)
    ![2011-10-10 00-12-05.png_thumb](/public/imported_attachments/1/2011-10-10 00-12-05.png_thumb)



  • Dependencies may break other packages.
    Instead of using it from 9 RELEASE, you can try(on lab) to install ezjail, download ports, compile your package, transfer libs to your pfsense box and see if it works.

    A lot of work, but if it works you can Open a redmine ticket to change make args of this package.

    EDIT:
    take a look at this tread
    http://forum.pfsense.org/index.php/topic,37471.0.html



  • Uh, you mean making/compiling 8.1 files of the 9 release source files or? (Shouldn't bother you with Q because of my total lack of knowledge on the subject…)

    I'm not at all familiar with the things you mention. But I'll certainly will try to read up on the subject.

    The link you provided is serial devices. The T750 is an USB device and the port= is set to auto. I tried setting to ugen0.2 but that didn't make it work. As I understand it the USB device ID, for my device, isn't present in NUT until version 2.4.2.

    For now I'll take my chances with dependency breakage...



  • ok, so just use it. No problem. :)

    Look for freebsd ports collection to know how freebsd packages works.


Locked