Performance on Soekris 1 GHz / 1 Gb ram



  • Hi,

    I am about to upgrade our router to a Soekris 6500 with 1 GHz Atom and 1 GB ram. It will be running captive portal and SquidGuard (filtering) for 100 users on 50 Mbit internet. It will also be routing between 4 LAN subnets.

    Will this setup be sufficient for that purpose ?

    /Daniel


  • Rebel Alliance Developer Netgate

    It should be fine for that, plenty of room to spare.

    I have one of the net6501 routers here but I haven't put much through it yet. It's pretty snappy in the limited testing I've done though.



  • The only issue I've had with mine is that the default powerd settings allow the system to throttle back WAY too far.  I've got to figure out how to change that so it doesn't drop to 250MHz.  That, combined with the default 2 allowed processes for the UI, makes for a very slow system when trying to make changes.  I changed the # of processes to 5 and it helped a little.  Soekris enabling HT might help as well, but they're taking their sweet time on it…



  • @Jason:

    The only issue I've had with mine is that the default powerd settings allow the system to throttle back WAY too far.  I've got to figure out how to change that so it doesn't drop to 250MHz.  That, combined with the default 2 allowed processes for the UI, makes for a very slow system when trying to make changes.  I changed the # of processes to 5 and it helped a little.  Soekris enabling HT might help as well, but they're taking their sweet time on it…

    The Atom architecture doesn't really benefit from throttling anyway.  Most of the power savings are implemented at the silicon level (the processor will power down transistors to save power without intervention from the OS).

    On the E6XX series, there is EIST and you should disable P4TCC throttling and load the EST module instead.  That will expose the actual speedstep frequencies and the response is much better than using P4TCC.

    Try adding the following to loader.conf.local and reboot:
    hint.p4tcc.0.disabled=1
    hint.acpi_throttle.0.disabled=1
    est_load="yes"



  • @dreamslacker:

    @Jason:

    The only issue I've had with mine is that the default powerd settings allow the system to throttle back WAY too far.  I've got to figure out how to change that so it doesn't drop to 250MHz.  That, combined with the default 2 allowed processes for the UI, makes for a very slow system when trying to make changes.  I changed the # of processes to 5 and it helped a little.  Soekris enabling HT might help as well, but they're taking their sweet time on it…

    The Atom architecture doesn't really benefit from throttling anyway.  Most of the power savings are implemented at the silicon level (the processor will power down transistors to save power without intervention from the OS).

    On the E6XX series, there is EIST and you should disable P4TCC throttling and load the EST module instead.  That will expose the actual speedstep frequencies and the response is much better than using P4TCC.

    Try adding the following to loader.conf.local and reboot:
    hint.p4tcc.0.disabled=1
    hint.acpi_throttle.0.disabled=1
    est_load="yes"

    Can I just create entries for those on the System Tunables page?



  • @Jason:

    Can I just create entries for those on the System Tunables page?

    I've never tried adding them to the tunables page, only via loader.conf.



  • @Jason:

    Can I just create entries for those on the System Tunables page?

    No, loader variables are not the same as sysctl tunables.


Log in to reply