ARP cache not working



  • Hello pfsense team and thanks for the superious stuff!

    Last week I saw a serious problem trying to implement pfsense in a papermachine network.

    I tried to migrate functionality of two Layer3 switches to two pfsense PCs:
    -atttached to each Layer3 Switch one pfsense PC
    -removed the routing from the layer3 switch
    -setup VLANs for bringing the packets from the layer3 switch ports to the pfsense PC
    -setup pfsense VLAN interfaces with static IP and CARP
    -everything was working properly at the first check

    Now the problem:
    -suddenly I werent able to reach IP addresses after they dropped out of the ARP cache because of timeout
    -no ARP-request were going out on the VLAN interface when trying a ping to these dropped addresses (checked with "Packet Capture")
    -the ARP cache showed me a "timeout" of entries but after "arp -d xxx.yyy.zzz.aaa" there were still no ARP requests going out, still the "timeout" message using "arp -a"
    -I cannot make further tests at the origin network (far away, loss of production)
    -I cannot reproduce it actually in office.
    -searching the web I have only found "switch" problems or one FreeBSD issue but without any answers

    Does somebody have seen something similar? Where should I try to dig around (CARP, VLAN, IP settup)?

    Thanks a lot,
    Klaus Pantleon


Locked