UK MLPPP Problem



  • Hi

    We currently have a problem getting MLPPP to work with Pfsense, it seems one line will come up ok but it has trouble to bundle the other. I know everything is set correct on the ISP side as this works fine with fixppp firmware on a WRT54g the reason i am not using it though is that over 20mbps on MLPPP with this router and we get very back packetloss.

    If any can hep me out would be much appriciated

    Here is a copy of my log -
    Oct 12 08:29:49 ppp: [wan_link0] PPPoE: Connecting to ''
    Oct 12 08:29:49 ppp: PPPoE: rec'd ACNAME "thn.bras1"
    Oct 12 08:29:49 ppp: [wan_link0] PPPoE: connection successful
    Oct 12 08:29:49 ppp: [wan_link0] Link: UP event
    Oct 12 08:29:49 ppp: [wan_link0] LCP: Up event
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Starting –> Req-Sent
    Oct 12 08:29:49 ppp: [wan_link0] LCP: SendConfigReq #221
    Oct 12 08:29:49 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:49 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM 30e2c964
    Oct 12 08:29:49 ppp: [wan_link0] MP MRRU 2048
    Oct 12 08:29:49 ppp: [wan_link0] MP SHORTSEQ
    Oct 12 08:29:49 ppp: [wan_link0] ENDPOINTDISC [802.1] 00 0d b9 20 a3 e8
    Oct 12 08:29:49 ppp: [wan_link0] LCP: rec'd Configure Request #1 (Req-Sent)
    Oct 12 08:29:49 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:49 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM ee52c76c
    Oct 12 08:29:49 ppp: [wan_link0] LCP: SendConfigAck #1
    Oct 12 08:29:49 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:49 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM ee52c76c
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Req-Sent –> Ack-Sent
    Oct 12 08:29:49 ppp: [wan_link0] LCP: rec'd Configure Reject #221 (Ack-Sent)
    Oct 12 08:29:49 ppp: [wan_link0] MP MRRU 2048
    Oct 12 08:29:49 ppp: [wan_link0] MP SHORTSEQ
    Oct 12 08:29:49 ppp: [wan_link0] LCP: SendConfigReq #222
    Oct 12 08:29:49 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:49 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM 30e2c964
    Oct 12 08:29:49 ppp: [wan_link0] LCP: rec'd Configure Ack #222 (Ack-Sent)
    Oct 12 08:29:49 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:49 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM 30e2c964
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Ack-Sent –> Opened
    Oct 12 08:29:49 ppp: [wan_link0] LCP: auth: peer wants CHAP, I want nothing
    Oct 12 08:29:49 ppp: [wan_link0] LCP: LayerUp
    Oct 12 08:29:49 ppp: [wan_link0] CHAP: rec'd CHALLENGE #1 len: 30
    Oct 12 08:29:49 ppp: [wan_link0] Name: "thn.bras1"
    Oct 12 08:29:49 ppp: [wan_link0] CHAP: Using authname "username"
    Oct 12 08:29:49 ppp: [wan_link0] CHAP: sending RESPONSE #1 len: 39
    Oct 12 08:29:49 ppp: [wan_link0] LCP: rec'd Configure Request #1 (Opened)
    Oct 12 08:29:49 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM 65819be0
    Oct 12 08:29:49 ppp: [wan_link0] MP MRRU 1524
    Oct 12 08:29:49 ppp: [wan_link0] ENDPOINTDISC [LOCAL] 6c 6e 73 30 2e 74 68 65 2e 75 6b
    Oct 12 08:29:49 ppp: [wan_link0] LCP: LayerDown
    Oct 12 08:29:49 ppp: [wan_link0] LCP: SendConfigReq #223
    Oct 12 08:29:49 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:49 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM 30e2c964
    Oct 12 08:29:49 ppp: [wan_link0] LCP: SendConfigAck #1
    Oct 12 08:29:49 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM 65819be0
    Oct 12 08:29:49 ppp: [wan_link0] MP MRRU 1524
    Oct 12 08:29:49 ppp: [wan_link0] ENDPOINTDISC [LOCAL] 6c 6e 73 30 2e 74 68 65 2e 75 6b
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Opened –> Ack-Sent
    Oct 12 08:29:49 ppp: [wan_link0] LCP: rec'd Configure Ack #223 (Ack-Sent)
    Oct 12 08:29:49 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:49 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:49 ppp: [wan_link0] MAGICNUM 30e2c964
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Ack-Sent –> Opened
    Oct 12 08:29:49 ppp: [wan_link0] LCP: auth: peer wants CHAP, I want nothing
    Oct 12 08:29:49 ppp: [wan_link0] LCP: LayerUp
    Oct 12 08:29:49 ppp: [wan_link0] CHAP: rec'd CHALLENGE #2 len: 32
    Oct 12 08:29:49 ppp: [wan_link0] Name: "lns0.the.uk"
    Oct 12 08:29:49 ppp: [wan_link0] CHAP: Using authname "username"
    Oct 12 08:29:49 ppp: [wan_link0] CHAP: sending RESPONSE #2 len: 39
    Oct 12 08:29:49 ppp: [wan_link0] CHAP: rec'd SUCCESS #2 len: 4
    Oct 12 08:29:49 ppp: [wan_link0] LCP: authorization successful
    Oct 12 08:29:49 ppp: [wan_link0] Can't join bundle wan without multilink negotiated.
    Oct 12 08:29:49 ppp: [wan_link0] link did not validate in bundle
    Oct 12 08:29:49 ppp: [wan_link0] LCP: parameter negotiation failed
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Opened –> Stopping
    Oct 12 08:29:49 ppp: [wan_link0] LCP: SendTerminateReq #224
    Oct 12 08:29:49 ppp: [wan_link0] LCP: LayerDown
    Oct 12 08:29:49 ppp: [wan_link0] rec'd proto IPCP during terminate phase
    Oct 12 08:29:49 ppp: [wan_link0] rec'd proto IPV6CP during terminate phase
    Oct 12 08:29:49 ppp: [wan_link0] LCP: rec'd Terminate Ack #224 (Stopping)
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Stopping –> Stopped
    Oct 12 08:29:49 ppp: [wan_link0] LCP: LayerFinish
    Oct 12 08:29:49 ppp: [wan_link0] PPPoE: connection closed
    Oct 12 08:29:49 ppp: [wan_link0] Link: DOWN event
    Oct 12 08:29:49 ppp: [wan_link0] LCP: Down event
    Oct 12 08:29:49 ppp: [wan_link0] LCP: state change Stopped –> Starting
    Oct 12 08:29:49 ppp: [wan_link0] LCP: LayerStart
    Oct 12 08:29:49 ppp: [wan_link0] Link: reconnection attempt 184 in 3 seconds
    Oct 12 08:29:52 ppp: [wan_link0] Link: reconnection attempt 184
    Oct 12 08:29:52 ppp: [wan_link0] PPPoE: Connecting to ''
    Oct 12 08:29:52 ppp: PPPoE: rec'd ACNAME "tch.bras1"
    Oct 12 08:29:52 ppp: [wan_link0] PPPoE: connection successful
    Oct 12 08:29:52 ppp: [wan_link0] Link: UP event
    Oct 12 08:29:52 ppp: [wan_link0] LCP: Up event
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Starting –> Req-Sent
    Oct 12 08:29:52 ppp: [wan_link0] LCP: SendConfigReq #225
    Oct 12 08:29:52 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:52 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 7c0cb4ae
    Oct 12 08:29:52 ppp: [wan_link0] MP MRRU 2048
    Oct 12 08:29:52 ppp: [wan_link0] MP SHORTSEQ
    Oct 12 08:29:52 ppp: [wan_link0] ENDPOINTDISC [802.1] 00 0d b9 20 a3 e8
    Oct 12 08:29:52 ppp: [wan_link0] LCP: rec'd Configure Request #1 (Req-Sent)
    Oct 12 08:29:52 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:52 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 2b8538cd
    Oct 12 08:29:52 ppp: [wan_link0] LCP: SendConfigAck #1
    Oct 12 08:29:52 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:52 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 2b8538cd
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Req-Sent –> Ack-Sent
    Oct 12 08:29:52 ppp: [wan_link0] LCP: rec'd Configure Reject #225 (Ack-Sent)
    Oct 12 08:29:52 ppp: [wan_link0] MP MRRU 2048
    Oct 12 08:29:52 ppp: [wan_link0] MP SHORTSEQ
    Oct 12 08:29:52 ppp: [wan_link0] LCP: SendConfigReq #226
    Oct 12 08:29:52 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:52 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 7c0cb4ae
    Oct 12 08:29:52 ppp: [wan_link0] LCP: rec'd Configure Ack #226 (Ack-Sent)
    Oct 12 08:29:52 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:52 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 7c0cb4ae
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Ack-Sent –> Opened
    Oct 12 08:29:52 ppp: [wan_link0] LCP: auth: peer wants CHAP, I want nothing
    Oct 12 08:29:52 ppp: [wan_link0] LCP: LayerUp
    Oct 12 08:29:52 ppp: [wan_link0] CHAP: rec'd CHALLENGE #1 len: 30
    Oct 12 08:29:52 ppp: [wan_link0] Name: "tch.bras1"
    Oct 12 08:29:52 ppp: [wan_link0] CHAP: Using authname "username"
    Oct 12 08:29:52 ppp: [wan_link0] CHAP: sending RESPONSE #1 len: 39
    Oct 12 08:29:52 ppp: [wan_link0] LCP: rec'd Configure Request #1 (Opened)
    Oct 12 08:29:52 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 6581a883
    Oct 12 08:29:52 ppp: [wan_link0] MP MRRU 1524
    Oct 12 08:29:52 ppp: [wan_link0] ENDPOINTDISC [LOCAL] 6c 6e 73 30 2e 74 68 65 2e 75 6b
    Oct 12 08:29:52 ppp: [wan_link0] LCP: LayerDown
    Oct 12 08:29:52 ppp: [wan_link0] LCP: SendConfigReq #227
    Oct 12 08:29:52 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:52 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 7c0cb4ae
    Oct 12 08:29:52 ppp: [wan_link0] LCP: SendConfigAck #1
    Oct 12 08:29:52 ppp: [wan_link0] AUTHPROTO CHAP MD5
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 6581a883
    Oct 12 08:29:52 ppp: [wan_link0] MP MRRU 1524
    Oct 12 08:29:52 ppp: [wan_link0] ENDPOINTDISC [LOCAL] 6c 6e 73 30 2e 74 68 65 2e 75 6b
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Opened –> Ack-Sent
    Oct 12 08:29:52 ppp: [wan_link0] LCP: rec'd Configure Ack #227 (Ack-Sent)
    Oct 12 08:29:52 ppp: [wan_link0] PROTOCOMP
    Oct 12 08:29:52 ppp: [wan_link0] MRU 1492
    Oct 12 08:29:52 ppp: [wan_link0] MAGICNUM 7c0cb4ae
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Ack-Sent –> Opened
    Oct 12 08:29:52 ppp: [wan_link0] LCP: auth: peer wants CHAP, I want nothing
    Oct 12 08:29:52 ppp: [wan_link0] LCP: LayerUp
    Oct 12 08:29:52 ppp: [wan_link0] CHAP: rec'd CHALLENGE #2 len: 32
    Oct 12 08:29:52 ppp: [wan_link0] Name: "lns0.the.uk"
    Oct 12 08:29:52 ppp: [wan_link0] CHAP: Using authname "username"
    Oct 12 08:29:52 ppp: [wan_link0] CHAP: sending RESPONSE #2 len: 39
    Oct 12 08:29:52 ppp: [wan_link0] CHAP: rec'd SUCCESS #2 len: 4
    Oct 12 08:29:52 ppp: [wan_link0] LCP: authorization successful
    Oct 12 08:29:52 ppp: [wan_link0] Can't join bundle wan without multilink negotiated.
    Oct 12 08:29:52 ppp: [wan_link0] link did not validate in bundle
    Oct 12 08:29:52 ppp: [wan_link0] LCP: parameter negotiation failed
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Opened –> Stopping
    Oct 12 08:29:52 ppp: [wan_link0] LCP: SendTerminateReq #228
    Oct 12 08:29:52 ppp: [wan_link0] LCP: LayerDown
    Oct 12 08:29:52 ppp: [wan_link0] rec'd proto IPCP during terminate phase
    Oct 12 08:29:52 ppp: [wan_link0] rec'd proto IPV6CP during terminate phase
    Oct 12 08:29:52 ppp: [wan_link0] LCP: rec'd Terminate Ack #228 (Stopping)
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Stopping –> Stopped
    Oct 12 08:29:52 ppp: [wan_link0] LCP: LayerFinish
    Oct 12 08:29:52 ppp: [wan_link0] PPPoE: connection closed
    Oct 12 08:29:52 ppp: [wan_link0] Link: DOWN event
    Oct 12 08:29:52 ppp: [wan_link0] LCP: Down event
    Oct 12 08:29:52 ppp: [wan_link0] LCP: state change Stopped –> Starting
    Oct 12 08:29:52 ppp: [wan_link0] LCP: LayerStart
    Oct 12 08:29:52 ppp: [wan_link0] Link: reconnection attempt 185 in 1 seconds



  • How do you have your wan interface set up?   Can you post a screen shot of your ppp page?

    Im suspecting a possible problem with at least one of your dsl circuits also.

    Mine for comparison…

    Oct 8 13:58:07 ppp: [wan_link1] LCP: rec'd Configure Request #2 (Ack-Rcvd)
    Oct 8 13:58:07 ppp: [wan_link1] MRU 1492
    Oct 8 13:58:07 ppp: [wan_link1] AUTHPROTO PAP
    Oct 8 13:58:07 ppp: [wan_link1] MAGICNUM a48beb99
    Oct 8 13:58:07 ppp: [wan_link1] MP MRRU 1524
    Oct 8 13:58:07 ppp: [wan_link1] ENDPOINTDISC [LOCAL] 52 34 5f 37 32 30 36
    Oct 8 13:58:07 ppp: [wan_link1] LCP: SendConfigAck #2
    Oct 8 13:58:07 ppp: [wan_link1] MRU 1492
    Oct 8 13:58:07 ppp: [wan_link1] AUTHPROTO PAP
    Oct 8 13:58:07 ppp: [wan_link1] MAGICNUM a48beb99
    Oct 8 13:58:07 ppp: [wan_link1] MP MRRU 1524
    Oct 8 13:58:07 ppp: [wan_link1] ENDPOINTDISC [LOCAL] 52 34 5f 37 32 30 36
    Oct 8 13:58:07 ppp: [wan_link1] LCP: state change Ack-Rcvd –> Opened
    Oct 8 13:58:07 ppp: [wan_link1] LCP: auth: peer wants PAP, I want nothing
    Oct 8 13:58:07 ppp: [wan_link1] PAP: using authname "User Name"
    Oct 8 13:58:07 ppp: [wan_link1] PAP: sending REQUEST #1 len: 21
    Oct 8 13:58:07 ppp: [wan_link1] LCP: LayerUp
    Oct 8 13:58:07 ppp: [wan_link1] PAP: rec'd ACK #1 len: 5
    Oct 8 13:58:07 ppp: [wan_link1] LCP: authorization successful
    Oct 8 13:58:07 ppp: [wan_link1] Link: Join bundle "wan"
    Oct 8 13:58:07 ppp: [wan] Bundle: Status update: up 2 links, total bandwidth 128000 bps

    What version of pfSense are you on?

    What model modems are you using?



  • All i have done on the WAN interface is set the username and password also the MTU to 1492

    Don't think there is anything wrong with circuits as it work ok with Tomato firmware on a WRT54g also if i disconnect the working link it will bring up the other it just cannot bundle them for some reason.

    Using the latest version 2.0RC and the modems are TPLINK TD-8616 in bridge mode but get the same result with netgear DG834's in bridge mode

    The isp have told me all they see their side is - Oct 12 10:18:24.019: %VPDN-6-CLOSED: L2TP LNS lns0.the.uk closed  user "username"; Result 2, Error 6, user-request/PPP Receive Term



  • You need to set this up on the ppp page.  https://"mypfsense"/interfaces_ppps.php

    You can reach this page from the wan page "Advanced and MLPPP"…




  • Hi

    Yer i have set the interfaces there and then set the WAN port to use the PPPOE?



  • @Seaniboy:

    Hi

    Yer i have set the interfaces there and then set the WAN port to use the PPPOE?

    Sorry missed this…

    Yep you do...    Have you got it working yet??



  • Hi

    Yer that was all set before but that is still the error i get  :'(

    I am playing about with a RB750G at the moment and it seems ok to work on that ok as welll, i just cannot get pfSense to bundle the lines???



  • What is showing up in your ISP's logs?



  • To be honest they are not giving me much, they tell me all they see their side is - %VPDN-6-CLOSED: L2TP LNS lns0.the.uk closed  user "username"; Result 2, Error 6, user-request/PPP Receive Term

    And that they have alot of clients using MLPPP with anything from linux boxes to Cisco CPE stuff



  • It looks like i am having the exact same problem as here - http://forum.pfsense.org/index.php/topic,36966.0/wap2.html

    I guess there was never a fix of this and i am sure my ISP use Cisco equipment their end  :(


Log in to reply