Bootloader on wrap problem



  • Hi all

    I've got
    a. a WRAP board
    b. two CF cards, one with an embedded image that works like charm,
    and one with a pfsense-dev installation that doesn't boot.

    I've transfered the embedded kernel across, made sure /etc/ttys has
    the serial console enabled, then realized the problem is none of the
    above.

    Looking at the serial console, I get stuck at this:

    ====
    F1  FreeBSD

    Default: F1

    <audible ding="">… [ several seconds pass ] …

    <ding>.. ad infinitum.

    No matter how I've tried to mess with the /boot/loader.conf,
    /boot/defaults/loader.conf and so forth, I never get past this bit.
    Obviously, I tried pressing F1, though I'm not sure SecureCRT maps
    that correctly, or how to make that happen if it doesn't.

    I don't know if this has any significance, but the bigger dev setup is
    installed on a BSD-partitioned /dev/ad4s1a, whereas the working
    embedded image has DOS-style /dev/ad4a partitioning. /etc/fstab points
    the correct way in both setups respectively, however I never get
    anywhere near the point where that file gets read so I don't think
    there's a problem there.

    Also interesting was the fact that nothing I did could clobber
    /boot/loader.rc, inspite of being root and having write access to the
    file (to modify it) and its directory (to delete it). In some bizarre
    way my UNIX knowledge does not appear to explain, that file is
    untouchable. :-\

    As the dev image is installed on a 2GB card (the embedded lives on a
    512M), I've also tried booting it as both CHS and as LBA set in
    tinyBIOS, to no avail.

    Can someone please offer some bootloader-kicking guidance?</ding></audible>


Log in to reply