Postfix Forwarder Antispam (Mailscanner + Spamassassin + clamav)



  • Hello,
    I am trying to move my Fedora-based postfix/amavis/spamassassin/clamav setup to pfSense now that there is support for Postfix.

    In trying to implement the third-party antispam settings on the AntiSpam tab of the Postfix Forwarder service, it says that I need to install these items.  I cannot find this information, so any direction on getting clamav/spamassassin installed, along with Mailscanner, that would be much appreciated.

    Regards,
    Chris



  • You can install all freeBDS packages on pfsense.

    Connect to console and then add packages with

    pkg_add
    

    To find which packages are available search the freeBSD package list.



  • I see that, but getting an error that it cannot find the package.  I think it is because the place it is looking does not exist.

    ftp://ftp.freebsd.org/pub/FreeBSD/ports/i386/packages-8.1-release/Latest/MailScanner

    In looking at this in a browser, there is no packages-8.1-release folder, but there is a packages-8.2-release folder.  Where can I can i change/add this updated path to the pfSense pkg_add configuration?

    regards,
    Chris



  • I'm working on this package(gui is almost done), but for now the core team did not finished compiling it to pfsense(they are currently working hard on 2.1 package structure).

    To manually add these packages, you must specify 8.2-release or 8-stable packages folder as freebsd 8.1-release is no longer available.

    Just try this on lab first, I'm not sure if some 8.2 mailscanner package or dependencie will break pfsense 2.0.

    MODIFY
    prefix for 8.1-relase packages:

    http://ftp-archive.freebsd.org/pub/FreeBSD-Archive/ports/amd64/packages-8.1-release/Latest/


Log in to reply