Can't write my access.log on my mountet USB-Drive



  • Hi everyone,

    i use pfsense on an alix-board.
    Now i want write logs from the squid-proxy at my mounted USB-Stick.

    I mount it with

    mount_msdosfs /dev/da0s1 /mnt

    all ok.

    But i get a Squid message:

    Oct 17 12:06:54 squid[56522]: Cannot open '/mnt/access.log' for writing. The parent directory must be writeable by the user 'proxy', which is the cache_effective_user set in squid.conf.

    When i try

    chmod 777 /mnt

    it happend nothing.

    A other try was create a files in /mnt named access.log
    and
    chmod 777 access.log

    But it haven't any result:
    -rwxr-xr-x  1 root  wheel        2 Oct 17 12:10 access.log

    Can anyone help me?

    thx gucky66



  • Change log folder owner to squid user.
    Thats what squid is asking you todo.

    After changing it, restart squid.



  • Hi marcelloc,

    yes i want to do this, but first i try the chmod command.

    But you see the result:

    the access.log wasn't change.

    May it's a problem with the
    / file system:
    [root@pfSense.local]/mnt(73): mount
    /dev/ufs/pfsense0 on / (ufs, local, read-only)

    How can i change the read-only ?



  • I do not use pfsense on embended system.

    So, not sure about this. Try to chance /etc/fstab.

    On packages, we call a mount_rw funtion before write config files.



  • Hi, i find the solution:

    i must change the read-only option:

    with:
    mount -uw /dev/ufs/pfsense0
    it switched off

    for switched on i use:
    mount -ur /dev/ufs/pfsense0

    THX –> to be closed


Log in to reply