Solution: FTP from LAN to WAN over SQUID.



  • Hi guys and girls
    I have had a huge problem getting FTP to work (using SQUID) from my LAN to my WAN.

    I have written a guideline for this and is available at:

    http://cyber7.l1fe.co.za/2011/10/20/pfsense-adding-the-ability-to-ftp-from-lan-to-wan/

    Basically the steps are:
    In SQUID: add thefollowing in your Custom Options: (NOTE: the ;;; is for new-lines)

    ;;;acl ftp proto FTP;http_access allow ftp;acl CONNECT method CONNECT;acl ftp_port port 21;;http_access allow ftp_port CONNECT;;;

    You also have to add in the Access Control/acl sslports the following: (NOTE: this enables the ports for FTP)

    21 50000-50050

    The last thing you need to do is disable your System Tunables “debug.pfftpproxy” by changing the “(default) 0″ value to “1″
    That is it…

    I use FileZilla’s free FTP client and it works like a charm.  Just remember to add your PROXY into the CLIENT.

    Kind regards
    Aubrey Kloppers
    Bible Society of SA



  • This solution did not work in my case.

    I  use SquidGuard. Is there any thing else that I could  try?

    Regards.
    Rafael


Locked