Upgrading 1.2.3 to 2.0 issue



  • Hello everyone,
    I've got this "Interface mismatch" issue after upgrading from 1.2.3 to 2.0.
    It seems like no matter what i try the system will never accept the interfaces.

    I'm running pfsense from a VM appliance.
    Does anyone know what could cause this error?

    thanks a lot.



  • I have a suspicion that some devices that used to be handled by the em driver are now handled by the igb driver. Suppose you had one such device and a fxp. Then your physical interface names used to be fxp0 and em0. Under 2.0 your interfaces will be named fxp0 and igb0 (no em0). Hence the startup will prompt you for the interface names because a configured interface (em0) is no longer present. When you are asked, if you keep on trying to configure em0 your attempt will fail because there is no em0.

    Some more details about your devices, the answers you are giving to the reassign interfaces request and the response you get would be helpful if what I described isn't the problem.



  • OK, I use vmware ESXi 4 so the network adapters are "E1000", which in windows recognize it as Intel(R) PRO/1000 MT Network Connection.

    Attached the screens, it doesn't matter what i enter, if it's not em(x) it won't work and if it is em(x) i get the same error message.

    from the config.xml file i can tell that the interfaces are em(x).

    Maybe changing the config.xml file manually will solve the problem, but how? ???

    Thanks!



  • Rebel Alliance Developer Netgate

    Make sure your config does not have any international characters in it from 1.2.3

    http://doc.pfsense.org/index.php/Upgrade_Guide#International.2FSpecial_Characters_in_1.2.x_Configs



  • Thanks, i already removed most of the config files content and then i restored it manually.  :(


Log in to reply