Support for Intel NIC 82579V in pfSense vs. 2



  • Im trying to setup a router using the Intel board DH61WW (Sandy Burst CPU) with psSense vs. 2. The boot process stops an some point and there is a message related to the Intel em driver. I guess it is the 82579V NIC that is causing the problem. I've also read the thread http://forum.pfsense.org/index.php/topic,39709.0.html that suggests that there should be support for this NIC since 2.0 RC3.

    When I deactivate the 82579V NIC in BIOS the boot process continues and stops much later due to another hardware problem (USB DVD drive cannot be mounted), but I'll take care of this (minor) issue once I know how to handle the NIC.

    The Intel em driver vs. 7.1.7 fro FreeBSD has support for this NIC, but my knowledge is insufficient to replace the drivers. Intel's installation instructions are not valid for pfSense.

    Could someone tell me whether the 82579V NIC is supposed to work, or how to setup and configure the updated driver?



  • http://forum.pfsense.org/index.php/topic,41643.0.html suggests that the NIC is not supported.



  • I bought a motherboard with the 82579V based upon the post from Bai Shen stating it was supported in 2.0 RC3. (http://forum.pfsense.org/index.php/topic,39709.msg205266.html#msg205266)

    Are you also using 2.0 RC3 and sure that it is not supported? :(

    Edit: I found out Intel has a new FreeBSD driver that supports the 82579V nic:

    http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=17509&ProdId=3299&lang=eng&OSVersion=FreeBSD

    FreeBSD* base driver for the Intel® Gigabit family of adapters, except for 82575/6, 82580, and I350-based gigabit network connections. This driver has been developed for use with FreeBSD* with the 7.x kernel.

    This means it should be possible to compile this into FreeBSD 8.1 and thus pfSense 2.0, right?


  • Netgate Administrator

    There has already been some work done on this to support some newer cards. I suggested something in this thread: http://forum.pfsense.org/index.php?;topic=40195.0
    But it was never confirmed. That file could be something else.

    Steve



  • You are refering to http://forum.pfsense.org/index.php/topic,40195.msg207880.html#msg207880 ?

    If so, if someone could explain me how to embed this driver into the 2.0 iso or from a live install, I'd be happily willing to test it.


  • Netgate Administrator

    Copy the file to /boot/modules (which will survive an update).
    The kldload the module to test it:

    kldload if_em
    

    Check the output to see if it loaded correctly. Since it's replacing an existing module it may not attach to the hardware that is already claimed.

    If it looks good that add: if_em_load='YES'
    to /boot/loader.conf.local.

    Steve



  • I tried to install the box using the release 2.0 version.

    I am currently waiting for some new hardware components (moboes and multiport Intel NICs). Once I have them, I'll try to install pfSense again and I'll look more carefully at the error messages. With the various hardware options I should then be able to see whether the specific board or the 82579V NIC (or some other component) is causing the problem. As I said, I have not come to the point that even the live OS is running on the DH61WW box.

    Steve: Thank you. If it is really a driver version problem, I'd compile the driver on a FreeBSD development box and then try to install it as described.



  • Just to be sure, you have the updated B3 version of the Intel DH61WW board, right?

    I have the exact same board as you, I will test it with both the standard 2.0 image as with the new driver loaded as soon as possible.

    Thanks for the howto, Steve :)



  • slth: yes–-but that also applies to other Intel moboes as well. I have a D510MO board, that has seen about a dozen Firmware updates (though I never had problems running pfSense 1 or 2 on them). Supermicro Atom boards are easier, but much more expensive...



  • Today, I finally got to testing pfSense on my config.

    I used the 2.0 RC3 image for pendrives (pfSense-memstick-2.0-RC3-i386-20110621-1650.img) and the 82579V NIC was detected without any problems during setup of the interfaces  ;D

    If I experience any problems I will report them here. The other nic in my setup is an old, but well supported, 3Com 3C905C-TX-M



  • I tried to install the pfSense 2.0 release version today again and made sure that I am using the latest BIOS update. The system still stalls when seeing the onboard NIC.

    Then I tried to run the Ubuntu Live CD and the system still chokes on seeing the 82579V NIC. I guess the onboard graphics chip is defect and I'll probably need to return the board. After disabling the onboard NIC, pfSense 2.0 installed fine.



  • Does this problem occur with the RC3 version of pfSense, or the latest 2.0 build?
    Also, I did not update the BIOS version, it worked straight out of the box.



  • It happens with the release version (the .iso file is dated 09/13/2011).

    I also tried a fresh Ubuntu install (and not just a hard disk from another machine with some manual adjustments, as I did before) from the CD and, voilá the NIC is recognized, the driver installs without problems, and the NIC operates correctly. So it is not a hardware problem.

    The board has been updated to the latest BIOS version 34 (10/18/2011).

    The other NICs are also Intel ones and they are recognized before the onboard NIC gets detected. I could try to remove these cards and see what happens then.



  • There was also a NIC problem with the Ubuntu Live CD, but after halting the machine and not just rebooting after pfSense has frozen the machine the problem no longer seems to appear.



  • I have given up to install pfSense 2.0 on a system with the Intel board DH61WW. It looks as if the problem is the newer 82579V NIC, but it might also be s.th. else.

    Nevertheless, Fedora 16 installs almost without problems. The system freezes if the onboard NIC is active when starting the Fedora Live CD. After disabling it, installing the OS, and updating the system, the NIC can be activated again and then the system and the NIC work smoothly. There were too many patches to see which drivers and chipset related packages were updated.

    There is a short article on phoronix.com about FreeBSD on Sandy Burst systems, which seems to suggest not use Sandy Burst boards at the moment, although none of the problems described there seem to be relevant for my setup.


Log in to reply