Huawei E220 UMTS Stick



  • Hello all together,

    I want to establish a Failover Connection of my PFsense-box via a UMTS-Stick. My choice was the Huawei E220 Stick which is on the "known working"-list:
    http://doc.pfsense.org/index.php/Known_Working_3G-4G_Modems

    Now I am fighting against this little thing since a few days and not finding anything in the www. Google just brings up very old topics within this forum.
    Following this tutorial I am not getting this stick to work.
    http://doc.pfsense.org/index.php/Configuring_3G_modems

    However on a native Windows box this stick works perfectly fine. I updated the stick since it came with an old firmware to this version: 11.117.10.03.99
    Sadly there was no change in behaviour.

    The System-PPP-Log say the following:

    It looks like there is no answer while starting the connection.

    My configuration lools like this:
    Interface-definition (only thing thats missing is provider and country - but after initial placement it just was gone and since this happens all the time this seems quiete normal?!

    After configureing the interface it shows up in the ppp list:

    And this is in the interfaces when I open the preferences (looks like the initial config-stuff).

    Anyone got this modem to work? I am obviously missing something since the modem itself must be ok (tested with the physical box).

    I am using latest PFsense (Release 2.0) on i386 based image.
    Your help is greatly appriciated.

    With best regards
    Thomas



  • Replying to the own threads sucks but I got it solved. And since I hate those threads were nobody says how here is my explanation:

    As you can see in the picture above I took /dev/cuaU2 because there was no other device. Well - this is exactly the problem because the modem has to report as /dev/cuaU0.
    I played around with some bios-settings regarding USB (legacy devices, etc) and also with the USB-Ports I used and somehow after a reboot I finally could see /dev/cuaU0 in the wizard. Guess what - since then it worked …


Log in to reply