Proxy not working if WAN is down

  • My pfsense setup is loadbalancing. I've squid and squidguard running. Now, my WAN got disconnected and I receive a complain that workstation has no browsing. I'm not really inside the local network. I was just accessing the pfsense remotely so I don't see any error on the workstation's browser if there's any. What I did is I turn off the Transparent Proxy and it seems the Loab Balancing kick in. It seems the culprit is whenever the WAN is down and Transparent Proxy is ON, workstation cannot browse. But when I turn off the Transparent Proxy, the loadbalancing rule was working.

    I enabled Allow default gateway switching and States in gateway Monitoring under System->Advance->Miscellaneous but still nothing happens.

    I've check if there are condition on proxy whenever WAN is down but cannot found any. Could it be a bug since I'm still using 2.0-RC3.

    Any recommendation?

  • Search for Squid and Floating rules.

Log in to reply