Dhcp with cable provider kernel arprequest: cannot find matching address


  • Hi,

    We regularly have a problem with our WAN, configured as DHCP with our cable provider. (Telenet)

    The connection goes down (sadly enough always during the night  ::) ) but when we notice it, a few hours later  ;), we only see the following lines (and a lot of them  :o).

    I suspect something with the DHCP lease/renew is going wrong?

    Oct 27 08:57:38 pfSense kernel: arprequest: cannot find matching address
    Oct 27 08:57:38 pfSense kernel: arprequest: cannot find matching address
    Oct 27 08:57:38 pfSense kernel: arprequest: cannot find matching address
    Oct 27 08:57:38 pfSense kernel: arprequest: cannot find matching address
    Oct 27 08:57:38 pfSense kernel: arprequest: cannot find matching address
    Oct 27 08:57:39 pfSense kernel: arprequest: cannot find matching address
    Oct 27 08:57:39 pfSense kernel: arprequest: cannot find matching address
    
    

    Our temp fix is now to unplug the cable going to the WAN modem (it's a standard cable modem) and plug it back in. After this, we get the normal dhcp fetch from the WAN interface. (i pasted this here: http://pastebin.com/40FXwcTY )

    Anything (besides configuring the WAN interface with a fixed IP) that I can do to troubleshoot or resolve this?

    Regards,
    Kristof.


  • I saw this twice last week which I've never seen before.  I have no idea what caused it but attributed it to the ISP since there were no errors in my logs.

    On Time Warner's Road Runner wideband service.


  • Hi,

    Ok, so it's not specifically Telenet in Belgium. Well, I did see it at several sites in Belgium. (but only managed to be quick enough this one time to capture some logging)

    Our ad-hoc solution would be to set the ip fixed. (we always get the same IP through DHCP on this site)

    That is no solution ofcourse for sites with dynamic IP addresses.

    cheers
    Kristof


  • Really nobody else experiencing this issue on 2.0 ?

    Cheers,
    Kristof.


  • Got the below in my cable modem logs last i saw the arprequest error, still not sure if this is an ISP error or something within pfSense

    Nov 29 2011 18:47:24 3-Critical R07.0 Unicast Ranging Received Abort Response - initializing MAC;CM-MAC=XX:XX:XX:XX:XX;CMTS-MAC=YY:YY:YY:YY:YY:YY;CM-QOS=1.1;CM-VER=3.0;
    Nov 29 2011 18:47:23 3-Critical R04.0 Received Response to Broadcast Maintenance Request, But no Unicast Maintenance opportunities received - T4 time out;CM-MAC=XX:XX:XX:XX:XX;CMTS-MAC=YY:YY:YY:YY:YY:YY;CM-QOS=1.1;CM-VER=3.0;
    Nov 29 2011 18:46:53 3-Critical R02.0 No Ranging Response received - T3 time-out;CM-MAC=XX:XX:XX:XX:XX;CMTS-MAC=YY:YY:YY:YY:YY:YY;CM-QOS=1.1;CM-VER=3.0;
    Nov 29 2011 18:46:44 4-Error C401.0 DCC-ACK not received;CM-MAC=XX:XX:XX:XX:XX;CMTS-MAC=YY:YY:YY:YY:YY:YY;CM-QOS=1.1;CM-VER=3.0;
    Nov 29 2011 18:46:44 3-Critical R02.0 No Ranging Response received - T3 time-out;CM-MAC=XX:XX:XX:XX:XX;CMTS-MAC=YY:YY:YY:YY:YY:YY;CM-QOS=1.1;CM-VER=3.0;


  • Hi,

    I've got an update on this. The error keeps coming back, sometimes the dhcp renewal doesn't seem to work. The only way to currently "fix" it is by rebooting (we don't do this because we lose the log files) or just unplugging the WAN interface for a few seconds.

    It seems the dhcp client on the WAN interface tries to request a new IP from the last DHCP server that responded, that is normal behaviour but our provider doesn't seem to like this.

    Any way to get around that so it does a DHCP request to 255.255.255.255 from the first try? (I know on linux there exists a dhcp parameter supersede dhcp-server-identifier 255.255.255.255)

    Jan 13 03:38:02 pfsense dhclient[58004]: DHCPREQUEST on rl1 to 195.130.132.102 port 67
    Jan 13 03:38:02 pfsense kernel: arpresolve: can't allocate llinfo for 81.82.192.1
    Jan 13 03:38:04 pfsense kernel: arprequest: cannot find matching address
    ...
    Jan 13 03:38:21 pfsense kernel: arprequest: cannot find matching address
    Jan 13 03:38:25 pfsense dhclient[58004]: DHCPREQUEST on rl1 to 255.255.255.255 port 67
    Jan 13 03:38:25 pfsense dhclient[58004]: DHCPACK from 81.82.192.1
    Jan 13 03:38:25 pfsense dhclient: RENEW
    Jan 13 03:38:25 pfsense dhclient: Creating resolv.conf
    Jan 13 03:38:25 pfsense dhclient[58004]: bound to 81.X.Y.Z -- renewal in 3600 seconds.
    Jan 13 03:38:26 pfsense kernel: arprequest: cannot find matching address
    ..
    Jan 13 04:38:22 pfsense kernel: arprequest: cannot find matching address
    Jan 13 04:38:25 pfsense dhclient[58004]: DHCPREQUEST on rl1 to 195.130.132.102 port 67
    Jan 13 04:38:25 pfsense kernel: arpresolve: can't allocate llinfo for 81.82.192.1
    
    

    I might be wrong of course but any suggestions to point me in the right direction are appreciated.

    A more complete log is attached.

    Thanks for any input,

    Kristof.

    [2012.01.13 PFSENSE.TXT](/public/imported_attachments/1/2012.01.13 PFSENSE.TXT)


  • Hello

    I'm using a Telenet Fibernet with pfSense2.0 and I am experiencing the same issue. Anyone found a solution for this one?