NAT (1:1) fails to forward traffic



  • Pfsense server public ip 208.43.30.118 Alias public ip : 208.43.30.117

    Private ip : 192.168.1.1

    Need to provide 1:1 NAT mapping to Vm in private network 192.168.1.5

    VM can also have public ip, just need to provide firewall and ids function to VMs (Web servers) in private network which is preferred Bridge mode or 1:1 NAT

    Iam unable to get 1:1 NAT working though it should be direct

    The output of

    $ pfctl -s rules

    scrub in on em0 all fragment reassemble scrub in on em1 all fragment reassemble anchor "relayd/" all block drop in log all label "Default deny rule" block drop out log all label "Default deny rule" block drop in quick inet6 all block drop out quick inet6 all block drop quick proto tcp from any port = 0 to any block drop quick proto tcp from any to any port = 0 block drop quick proto udp from any port = 0 to any block drop quick proto udp from any to any port = 0 block drop quick from <snort2c>to any label "Block snort2c hosts" block drop quick from any to <snort2c>label "Block snort2c hosts" block drop in log quick proto carp from (self) to any pass quick proto carp all keep state pass quick proto pfsync all keep state block drop in log quick proto tcp from <sshlockout>to any port = ssh label "sshlockout" block drop in log quick proto tcp from <webconfiguratorlockout>to any port = http label "webConfiguratorlockout" block drop in quick from <virusprot>to any label "virusprot overload table" block drop in log quick on em0 from <bogons>to any label "block bogon networks from WAN" block drop in on ! em0 inet from 208.43.30.112/29 to any block drop in inet from 208.43.30.118 to any block drop in inet from 208.43.30.117 to any block drop in on ! em1 inet from 192.168.1.0/24 to any block drop in inet from 192.168.1.1 to any block drop in on em0 inet6 from fe80::250:56ff:fe8b:571e to any block drop in on em1 inet6 from fe80::250:56ff:fe8b:571f to any pass in on lo0 all flags S/SA keep state label "pass loopback" pass out on lo0 all flags S/SA keep state label "pass loopback" pass out all flags S/SA keep state allow-opts label "let out anything from firewall host itself" pass out route-to (em0 208.43.30.113) inet from 208.43.30.118 to ! 208.43.30.112/29 flags S/SA keep state allow-opts label "let out anything from firewall host itself" pass in quick on em1 proto tcp from any to (em1) port = http flags S/SA keep state label "anti-lockout rule" anchor "userrules/" all pass in quick on em0 reply-to (em0 208.43.30.113) inet proto tcp from any to 192.168.1.5 port = http flags S/SA keep state label "USER_RULE: allow webtraffic" pass in quick on em1 inet from 192.168.1.0/24 to any flags S/SA keep state label "USER_RULE: Default allow LAN to any rule" anchor "tftp-proxy/*" all

    I tried setting it up a few times with port forward as well as 1:1 NAt But traffic does not forward to the internal ip.

    Thanks</bogons></virusprot></webconfiguratorlockout></sshlockout></snort2c></snort2c>



  • I think a screen shot of your rules for WAN and LAN would be more effective for most people or clean up that rule dump with new lines.


Locked