1.2.3 to 2.0 –> RAID/mount problem



  • 2 or 3 years ago I installed a PFSense 1.2.3 and configured a software RAID 1 using gmirror (Using embedded HW RAID don't work in the IBM xSeries 236 and neither to some other HP servers).
    No problem until today when I upgraded this installation to 2.0
    After upgrade, the box don't boot. Seems it can't mount the system.
    But if I boot selecting "Safe Mode" (option 4 from boot menu), all seems Ok.

    I think there is something to "fix", but before to try using my limited knowledge of BSD disks handling and risk to do more damages, it is better to ask if someone can give me some useful hints ;-)

    below some configs settins.

    Thanks, P.

    cat /etc/fstab

    Device                Mountpoint      FStype  Options        Dump    Pass#

    /dev/mirror/gm0s1a              /              ufs    rw              1      1
    /dev/mirror/gm0s1b              none            swap    sw              0      0

    gmirror status

    Name    Status  Components
    mirror/gm0  COMPLETE  da0
                                    da1

    sysctl kern.geom.debugflags

    kern.geom.debugflags: 0

    cat /boot/loader.conf

    autoboot_delay="3"
    vm.kmem_size="435544320"
    vm.kmem_size_max="535544320"
    kern.ipc.nmbclusters="0"
    geom_mirror_load=YES

    df

    Filesystem        1K-blocks  Used    Avail Capacity  Mounted on
    /dev/mirror/gm0s1a 136828888 278460 125604118    0%    /
    devfs                      1      1        0  100%    /dev
    /dev/md0                3694    50      3350    1%    /var/run


  • Rebel Alliance Developer Netgate

    What is the actual error you see when it can't mount the drive?



  • This is the screenshot of the failed boot (not a great photo, but hope understandable)

    Thanks, P.



  • Rebel Alliance Developer Netgate

    It's ok, it's still legible.

    Can you press scroll lock, hit page up and look for anything else related to gm0 or gmirror? And at the prompt can you list the available drives?

    There isn't much in that one, just the mount failure, which looks like it just can't find the mount device, which could be for several different reasons.



  • I did other tests (but now need to stop or my users …)
    Tried selecting Boot Option 2 (ACPI Disabled); the box boot as if I select Boot Option 4 (Safe Mode).
    I did some screenshot of the boot process (selected verbose logging boot), scrolling as you suggested (not good quality but hope understable).
    I didn't notice anything of useful. But my *BSD knowledge is limited.

    attach below.

    Thanks, P.























  • Rebel Alliance Developer Netgate

    Can't really see anything that looks out of line, but it does mention a lot of ACPI/APIC issues. You might check for a BIOS update.

    Safe mode disables several things that may be letting it get farther:
    It does:

    • Does not load ACPI, and explicitly disables it
    • Disables APIC
    • Disables DMA
    • Disables write caching
    • A couple other bits that do not probably affect anything (eisa, keyboard demux)


  • Thanks for diagnosys.
    The box is an old IBM xSeries 236. I prefer do not update the BIOS if possible.
    It worked fine with PFSense 1.2.3.

    There is a way to config the boot loader to force the default boot to not load ACPI?

    Thanks, P.


  • Rebel Alliance Developer Netgate

    Yes, check the doc wiki.



  • Solved.

    Thanks, P.

    For interested, the solution was:

    echo "hint.acpi.0.disabled=1" >> /boot/loader.conf.local


Locked